DSpace has a possible Path Traversal Vulnerability in its Curation Task Reporter output path
CVE-2026-49831GHSA-v66x-68f2-pxf5
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.dspace:dspace-api 10.0, 9.3, 8.4, 7.6.7), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.dspace:dspace-api
- Affected
- <= 7.6.6>= 8.0-rc1, <= 8.3>= 9.0-rc1, <= 9.2>= 10-rc1, <= 10-rc1
- Fixed in
- 10.0, 7.6.7, 9.3, 8.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-v66x-68f2-pxf5 lists affected ranges: Maven org.dspace:dspace-api >=0 =8.0-rc1 =9.0-rc1 =10-rc1 <=10-rc1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.5 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:L/A:H
- EPSS
- CVE-2026-49831: 0.53% estimated exploitation activity in the next 30 days; percentile 44.66 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Overview The Curation Task feature allows an output path to be used by the reporter (-r parameter), typically used to stream results and status of curation task operations. It is not restricted to any particular base path, meaning that any path writable by the DSpace (often 'tomcat') user is allowed. This constitutes a Path Traversal Vulnerability in the curate script. This was not a real problem when curation tasks could only be run from the command-line as a system administrator, but now that Collection/Community/Site Administrators can also run curation tasks via the web user interface, it introduces a possibility for an attacker with DSpace administrative credentials to set command parameters in such a way that output ends up in an unexpected location (for example, static resources folder in the Spring boot webapp, or overwriting a configuration file). This vulnerability impacts DSpace versions <= 7.6.6, 8.0 <= 8.3, 9.0 <= 9.2. The attacker MUST already have DSpace…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-v66x-68f2-pxf5
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-49831 Advisory: DSpace has a possible Path Traversal Vulnerability in its Curation Task Reporter output path IDs: CVE-2026-49831, GHSA-v66x-68f2-pxf5 Record: https://patchnext.com/advisories/cve-2026-49831 (revision 1, source checked 26 Oct 2026, 16:54 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.dspace:dspace-api 10.0, 9.3, 8.4, 7.6.7. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.dspace:dspace-api: affected <= 7.6.6; >= 8.0-rc1, <= 8.3; >= 9.0-rc1, <= 9.2; >= 10-rc1, <= 10-rc1; fixed in 10.0, 7.6.7, 9.3, 8.4 ## Suggested inspection (read-only) - Maven org.dspace:dspace-api: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.dspace:dspace-api. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-v66x-68f2-pxf5 (GitHub-reviewed advisory GHSA-v66x-68f2-pxf5 lists affected ranges: Maven org.dspace:dspace-api >=0 =8.0-rc1 =9.0-rc1 =10-rc1 <=10-rc1) Commands are suggestions: review each one before running it.
Loading voting…