Skip to content

← Actionable
Medium, CVSS 4.4

DSpace: ORE resource URI does not validate scheme for non-web resources

CVE-2026-49830GHSA-c827-pw3m-67w7

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.dspace:dspace-api 10.0, 9.3, 8.4, 7.6.7), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Maven org.dspace:dspace-api

    Affected
    <= 7.6.6>= 8.0-rc1, <= 8.3>= 9.0-rc1, <= 9.2>= 10-rc1, <= 10-rc1
    Fixed in
    10.0, 7.6.7, 9.3, 8.4

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.4 · CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2026-49830: 0.49% estimated exploitation activity in the next 30 days; percentile 42.13 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Overview When ingesting an aggregated ORE resource by URI (using the OAI-ORE Harvester)), the ORE Ingestion Crosswalk does not validate the URI scheme. This may allow for local file inclusion via malicious paths like file:///etc/passwd. This vulnerability impacts DSpace versions <= 7.6.6, 8.0 <= 8.3, 9.0 <= 9.2. The attacker MUST already have DSpace collection administrator privileges in order to perform the attack. Expected behaviour : Only external web resources should be ingested as ORE resources, preferably from the trusted endpoint. Impact A remote OAI endpoint configured as a harvest source for a DSpace collection can supply malicious ORE XML that results in a local file from the DSpace server being ingested as a bitstream. Only Collection, Community and Site Administrators can configure a collection for OAI harvest, however an attacker may use stolen credentials to escalate into local file/data disclosure, or a compromised OAI endpoint could also supply malicious XML. Patches…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-c827-pw3m-67w7

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-49830

Advisory: DSpace: ORE resource URI does not validate scheme for non-web resources
IDs: CVE-2026-49830, GHSA-c827-pw3m-67w7
Record: https://patchnext.com/advisories/cve-2026-49830 (revision 1, source checked 26 Oct 2026, 16:54 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.dspace:dspace-api 10.0, 9.3, 8.4, 7.6.7. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.dspace:dspace-api: affected <= 7.6.6; >= 8.0-rc1, <= 8.3; >= 9.0-rc1, <= 9.2; >= 10-rc1, <= 10-rc1; fixed in 10.0, 7.6.7, 9.3, 8.4

## Suggested inspection (read-only)
- Maven org.dspace:dspace-api: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.dspace:dspace-api.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-c827-pw3m-67w7 (GitHub-reviewed advisory GHSA-c827-pw3m-67w7 lists affected ranges: Maven org.dspace:dspace-api >=0 =8.0-rc1 =9.0-rc1 =10-rc1 <=10-rc1)

Commands are suggestions: review each one before running it.

Loading voting…