Soup Sieve has Memory Exhaustion via Large Comma-Separated Selector Lists
CVE-2026-49476GHSA-2wc2-fm75-p42x
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (soupsieve 2.8.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI soupsieve
- Affected
- <= 2.8.3
- Fixed in
- 2.8.4
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-2wc2-fm75-p42x lists affected ranges: PyPI soupsieve >=0 <2.8.4 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-2wc2-fm75-p42x lists affected ranges: PyPI soupsieve >=0 <=2.8.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2026-49476: 0.64% estimated exploitation activity in the next 30 days; percentile 50.92 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The CSS selector parser in soupsieve (the CSS selector engine for Beautiful Soup 4) allocates unbounded memory when compiling large comma-separated selector lists. An attacker who can supply a crafted CSS selector string to soupsieve.compile() or Beautiful Soup's .select() / .selectone() can cause the application to allocate hundreds of megabytes of heap memory from a relatively small input, leading to memory exhaustion and denial of service. To be completely transparent, AI tools helped surface this issue. However, it was independently reproduced and carefully validated. Researchers follow responsible disclosure practices and originally shared this report privately. A 500 KB selector string triggers allocation of approximately 244 MB of heap memory - a 488x— amplification ratio. Details Affected code: soupsieve/cssparser.py, lines ~204, 925, 1106 The soupsieve CSS parser splits comma-separated selector lists and creates one CSSSelector object per list item. Each CSSSelector…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-2wc2-fm75-p42x
- Revision 1 · created ·
Published from osv record GHSA-2wc2-fm75-p42x
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-49476 Advisory: Soup Sieve has Memory Exhaustion via Large Comma-Separated Selector Lists IDs: CVE-2026-49476, GHSA-2wc2-fm75-p42x Record: https://patchnext.com/advisories/cve-2026-49476 (revision 2, source checked 26 Oct 2026, 13:46 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: soupsieve 2.8.4. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI soupsieve: affected <= 2.8.3; fixed in 2.8.4 ## Suggested inspection (read-only) - `python -m pip show soupsieve`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on soupsieve. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-2wc2-fm75-p42x (OSV record GHSA-2wc2-fm75-p42x lists affected ranges: PyPI soupsieve >=0 <2.8.4 (fixed)) - Verified: https://github.com/advisories/GHSA-2wc2-fm75-p42x (GitHub-reviewed advisory GHSA-2wc2-fm75-p42x lists affected ranges: PyPI soupsieve >=0 <=2.8.3) Commands are suggestions: review each one before running it.
Loading voting…