Skip to content

← Actionable
Critical, CVSS 9.5amended

LiteLLM: Authentication Bypass via Host Header Injection

CVE-2026-49468GHSA-4xpc-pv4p-pm3w

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (litellm 1.84.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI litellm

    Affected
    < 1.84.0
    Fixed in
    1.84.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
9.5 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H · score source
EPSS
  • CVE-2026-49468: 3.03% estimated exploitation activity in the next 30 days; percentile 87.51 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact A Host-header parsing flaw in the LiteLLM proxy could, under specific conditions, allow unauthenticated access to protected management routes. The auth layer derived the effective route from request.url.path in litellm/proxy/auth/authutils.py::getrequestroute(), which Starlette reconstructs from the Host header. A crafted Host could therefore make the auth gate evaluate a different route from the one FastAPI dispatched. Most deployments are not affected. The bypass is blocked by any upstream layer that validates or normalizes Host, such as: - a CDN or WAF, such as Cloudflare - a reverse proxy with servername allowlists - a host-based load balancer LiteLLM Cloud customers are not affected. Patches Fixed in 1.84.0. Upgrade to 1.84.0 or later. No configuration change is required. Workarounds If upgrading is not immediately possible, place the proxy behind an upstream component that validates or normalizes the Host header before forwarding (a CDN/WAF, a reverse proxy with explicit…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from ghsa record GHSA-4xpc-pv4p-pm3w

  2. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 2 · amended ·

    Amended from osv record GHSA-4xpc-pv4p-pm3w

  4. Revision 1 · created ·

    Published from ghsa record GHSA-4xpc-pv4p-pm3w

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-49468

Advisory: LiteLLM: Authentication Bypass via Host Header Injection
IDs: CVE-2026-49468, GHSA-4xpc-pv4p-pm3w
Record: https://patchnext.com/advisories/cve-2026-49468 (revision 4, source checked 26 Oct 2026, 13:49 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: litellm 1.84.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI litellm: affected < 1.84.0; fixed in 1.84.0

## Suggested inspection (read-only)
- `python -m pip show litellm`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on litellm.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-4xpc-pv4p-pm3w (GitHub-reviewed advisory GHSA-4xpc-pv4p-pm3w lists affected ranges: PyPI litellm >=0 <1.84.0)
- Verified: https://osv.dev/vulnerability/GHSA-4xpc-pv4p-pm3w (OSV record GHSA-4xpc-pv4p-pm3w lists affected ranges: PyPI litellm >=0 <1.84.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…