Skip to content

← Actionable
Low, CVSS 3.1amended

Waku has an Open Redirect via unstable_redirect Helper

CVE-2026-49456GHSA-43fc-v873-qw85

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (waku 1.0.0-beta.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm waku

    Affected
    <= 1.0.0-beta.0
    Fixed in
    1.0.0-beta.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
3.1 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:N/I:L/A:N
EPSS
  • CVE-2026-49456: 0.40% estimated exploitation activity in the next 30 days; percentile 34.04 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The unstableredirect() helper exported from waku/router/server (packages/waku/src/router/define-router.tsx:156–161) accepts an arbitrary string and reflects it unchanged into the HTTP Location response header with no URL validation, scheme restriction, or path-only enforcement. Any application that passes user-controlled input to this helper — the natural pattern documented in the JSDoc and official fixtures — is vulnerable to open redirect attacks. An attacker who convinces a victim to click a crafted link can silently redirect the browser to an arbitrary external domain, enabling phishing, credential harvesting, and OAuth token theft. Additionally, scheme-relative URLs (//evil.example/) bypass naive https?://-only allow-list filters that developers might add as ad-hoc mitigations. Dynamic PoC confirmed against waku 1.0.0-beta.0 (commit 8e9f542) in an isolated Docker environment. Two independent dynamic runs produced identical results. --- Root Cause…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-43fc-v873-qw85

  2. Revision 1 · created ·

    Published from osv record GHSA-43fc-v873-qw85

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-49456

Advisory: Waku has an Open Redirect via `unstable_redirect` Helper
IDs: CVE-2026-49456, GHSA-43fc-v873-qw85
Record: https://patchnext.com/advisories/cve-2026-49456 (revision 2, source checked 26 Oct 2026, 12:56 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 3.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: waku 1.0.0-beta.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm waku: affected <= 1.0.0-beta.0; fixed in 1.0.0-beta.1

## Suggested inspection (read-only)
- `npm ls waku --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on waku.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-43fc-v873-qw85 (OSV record GHSA-43fc-v873-qw85 lists affected ranges: npm waku >=0 <1.0.0-beta.1 (fixed))
- Verified: https://github.com/advisories/GHSA-43fc-v873-qw85 (GitHub-reviewed advisory GHSA-43fc-v873-qw85 lists affected ranges: npm waku >=0 <=1.0.0-beta.0)

Commands are suggestions: review each one before running it.

Loading voting…