Cilium vulnerable to sensitive information disclosure and cluster disruption via local Envoy admin socket access
CVE-2026-49445GHSA-3fcv-jvfp-m4q9
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/cilium/cilium 1.19.2, 1.18.8, 1.17.14), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- >= 1.19.0, < 1.19.2>= 1.18.0, < 1.18.8< 1.17.14
- Fixed in
- 1.17.14, 1.19.2, 1.18.8
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-3fcv-jvfp-m4q9 lists affected ranges: Go github.com/cilium/cilium >=1.19.0 =1.18.0 =0 <1.17.14
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.2 · CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:C/C:H/I:L/A:H
- EPSS
- CVE-2026-49445: 0.17% estimated exploitation activity in the next 30 days; percentile 5.83 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact When Cilium L7 functionality is enabled on a cluster, the Envoy instance supporting this functionality creates a world-accessible socket on cluster nodes. A local attacker would be able to access Envoy admin endpoints. Depending on deployment configuration, this can expose sensitive information or allow disruptive administrative operations, such as: - Exposing TLS secrets - Disrupting traffic in the cluster - Terminating the Envoy process This issue affects both the embedded and standalone Envoy deployment models. Patches This issue affects: - Cilium v1.19 between v1.19.0 and v1.19.1 inclusive - Cilium v1.18 between v1.18.0 and v1.18.7 inclusive - All versions of Cilium prior to v1.17.14 This issue has been patched in https://github.com/cilium/cilium/pull/44512, included in: - Cilium v1.19.2 - Cilium v1.18.8 - Cilium v1.17.14 Workarounds There is no known workaround to this issue. Acknowledgements The Cilium community has worked together with members of Isovalent to prepare…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-3fcv-jvfp-m4q9
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-49445 Advisory: Cilium vulnerable to sensitive information disclosure and cluster disruption via local Envoy admin socket access IDs: CVE-2026-49445, GHSA-3fcv-jvfp-m4q9 Record: https://patchnext.com/advisories/cve-2026-49445 (revision 1, source checked 26 Oct 2026, 15:24 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/cilium/cilium 1.19.2, 1.18.8, 1.17.14. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/cilium/cilium: affected >= 1.19.0, < 1.19.2; >= 1.18.0, < 1.18.8; < 1.17.14; fixed in 1.17.14, 1.19.2, 1.18.8 ## Suggested inspection (read-only) - Go github.com/cilium/cilium: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/cilium/cilium. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-3fcv-jvfp-m4q9 (GitHub-reviewed advisory GHSA-3fcv-jvfp-m4q9 lists affected ranges: Go github.com/cilium/cilium >=1.19.0 =1.18.0 =0 <1.17.14) Commands are suggestions: review each one before running it.
Loading voting…