Deno: BYONM module resolution allows package.json main path traversal to bypass --allow-read restrictions
CVE-2026-49406GHSA-968w-xfqw-vp9q
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (deno 2.7.12), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
crates.io deno
- Affected
- <= 2.7.11
- Fixed in
- 2.7.12
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-968w-xfqw-vp9q lists affected ranges: crates.io deno >=0 <=2.7.11
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.5 · CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2026-49406: 0.18% estimated exploitation activity in the next 30 days; percentile 7.09 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary When Deno was run in BYONM mode (nodeModulesDir: "manual"), the module resolver did not validate that a package's resolved entrypoint stayed within its nodemodules/<pkg/ directory. A malicious package.json whose main field contained .. segments was able to resolve to an arbitrary path on disk, and the resolver then read that file without consulting the --allow-read allowlist. This let a require("evil-pkg") call return the contents of a file that a direct Deno.readTextFileSync(...) call would have been blocked from reading. Details In BYONM mode, Deno resolved npm packages directly from a user-managed nodemodules tree. Resolution of require("pkg") proceeded by reading pkg/package.json, taking the main field, joining it to the package directory, and loading the result as a module. The path joined from main was not constrained to the package root. A package.json such as: resolved to nodemodules/pkg/../../../secret.json, escaping nodemodules entirely. The BYONM permission check…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-968w-xfqw-vp9q
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-49406 Advisory: Deno: BYONM module resolution allows `package.json` main path traversal to bypass `--allow-read` restrictions IDs: CVE-2026-49406, GHSA-968w-xfqw-vp9q Record: https://patchnext.com/advisories/cve-2026-49406 (revision 1, source checked 26 Oct 2026, 15:43 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: deno 2.7.12. A vendor fix does not mean a deployment is fixed. ## Affected components - crates.io deno: affected <= 2.7.11; fixed in 2.7.12 ## Suggested inspection (read-only) - crates.io deno: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on deno. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-968w-xfqw-vp9q (GitHub-reviewed advisory GHSA-968w-xfqw-vp9q lists affected ranges: crates.io deno >=0 <=2.7.11) Commands are suggestions: review each one before running it.
Loading voting…