Skip to content

← Actionable
Low, CVSS 3.3amended

October CMS: PHP Object Injection via Backend Widget Session Storage

CVE-2026-49400GHSA-2ff2-mx52-q8wp

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (october/system 4.2.23, 3.7.17), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist october/system

    Affected
    < 3.7.17>= 4.0.0, < 4.2.23
    Fixed in
    4.2.23, 3.7.17

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
3.3 · CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:L/I:L/A:N
EPSS
  • CVE-2026-49400: 0.24% estimated exploitation activity in the next 30 days; percentile 14.80 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The backend SessionMaker trait stored widget session state as base64(serialize(...)) and consumed it with unserialize() without an allowedclasses restriction. Any code path that could write to a widget. session key with attacker-controlled bytes could trigger PHP object injection the next time the widget read its session state, allowing instantiation of arbitrary classes and reachable PHP gadget chains. This issue only affects installations running with cms.safemode enabled. Safe Mode is a niche opt-in feature, primarily used for demo installations and multi-tenant or shared-editor scenarios where untrusted users are deliberately granted access to the CMS markup editor. In standard production deployments Safe Mode is off, backend access is restricted to trusted administrators, and a markup editor can already execute arbitrary PHP directly. The session-write path that reaches this sink is gated by the Safe Mode sandbox, so installations without Safe Mode enabled are not exposed. Scope…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-2ff2-mx52-q8wp

  2. Revision 1 · created ·

    Published from osv record GHSA-2ff2-mx52-q8wp

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-49400

Advisory: October CMS: PHP Object Injection via Backend Widget Session Storage
IDs: CVE-2026-49400, GHSA-2ff2-mx52-q8wp
Record: https://patchnext.com/advisories/cve-2026-49400 (revision 2, source checked 26 Oct 2026, 14:53 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 3.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: october/system 4.2.23, 3.7.17. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist october/system: affected < 3.7.17; >= 4.0.0, < 4.2.23; fixed in 4.2.23, 3.7.17

## Suggested inspection (read-only)
- Packagist october/system: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on october/system.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-2ff2-mx52-q8wp (OSV record GHSA-2ff2-mx52-q8wp lists affected ranges: Packagist october/system >=0 =4.0.0 <4.2.23 (fixed))
- Verified: https://github.com/advisories/GHSA-2ff2-mx52-q8wp (GitHub-reviewed advisory GHSA-2ff2-mx52-q8wp lists affected ranges: Packagist october/system >=0 =4.0.0 <4.2.23)

Commands are suggestions: review each one before running it.

Loading voting…