Skip to content

← Actionable
High, CVSS 7.8amended

Recce server has unauthenticated SQL execution that allows local file read/write through DuckDB

CVE-2026-49360GHSA-rh62-j648-g5qc

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (recce 1.50.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI recce

    Affected
    <= 1.49.0
    Fixed in
    1.50.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.8 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:L/SI:H/SA:N · score source
EPSS
  • CVE-2026-49360: 1.07% estimated exploitation activity in the next 30 days; percentile 65.00 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Recce OSS server deployments that expose the server to an untrusted network without authentication are vulnerable to unauthenticated SQL execution through the query run API. When Recce is configured with a DuckDB-backed project, an attacker can use DuckDB filesystem primitives to read and write files accessible to the Recce server process. The impact depends on how Recce is deployed, but may include disclosure of local files, tampering with Recce/dbt artifacts, modification of browser-served static files leading to stored XSS, and modification of application files if those paths are writable. If Recce is run as root, file access occurs with root privileges inside that host or container. Patches This issue has been patched in Recce v1.50.0. Users should upgrade to Recce v1.50.0 or later. The patch restricts unsafe file read/write behavior for DuckDB-backed query execution and hardens the affected query path. Other warehouse adapters have also been reviewed for similar exposure.…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-rh62-j648-g5qc

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-rh62-j648-g5qc

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-49360

Advisory: Recce server has unauthenticated SQL execution that allows local file read/write through DuckDB
IDs: CVE-2026-49360, GHSA-rh62-j648-g5qc
Record: https://patchnext.com/advisories/cve-2026-49360 (revision 3, source checked 26 Oct 2026, 13:46 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: recce 1.50.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI recce: affected <= 1.49.0; fixed in 1.50.0

## Suggested inspection (read-only)
- `python -m pip show recce`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on recce.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-rh62-j648-g5qc (OSV record GHSA-rh62-j648-g5qc lists affected ranges: PyPI recce >=0 <1.50.0 (fixed))
- Verified: https://github.com/advisories/GHSA-rh62-j648-g5qc (GitHub-reviewed advisory GHSA-rh62-j648-g5qc lists affected ranges: PyPI recce >=0 <=1.49.0)

Commands are suggestions: review each one before running it.

Loading voting…