PhpWeasyPrint vulnerable to SSRF and local file disclosure via the attachment option
CVE-2026-49359GHSA-x8g9-h984-pc36
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (pontedilana/php-weasyprint 2.6.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist pontedilana/php-weasyprint
- Affected
- <= 2.5.1
- Fixed in
- 2.6.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-x8g9-h984-pc36 lists affected ranges: Packagist pontedilana/php-weasyprint >=0 <=2.5.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2026-49359: 0.42% estimated exploitation activity in the next 30 days; percentile 36.59 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary pontedilana/php-weasyprint fetches the content of option values server-side via filegetcontents() when the value looks like a URL, without restricting the URL scheme. The attachment option of Pdf is the reachable sink: any value that passes isOptionUrl() (filtervar(..., FILTERVALIDATEURL)) is downloaded by the PHP process and embedded into the generated PDF. Because FILTERVALIDATEURL accepts http, https, ftp, file and PHP stream wrappers such as php://, an attacker who can influence the attachment value reaches both a Server-Side Request Forgery primitive (e.g. internal HTTP endpoints, cloud metadata) and a local file disclosure primitive (file://, php://filter/...), with the fetched bytes exfiltrated as a PDF attachment. This is the same class of issue KnpLabs/snappy patched for its xsl-style-sheet option in GHSA-c5fp-p67m-gq56. The library is documented as a one-to-one substitute for KnpLabs/snappy and shares the same code shape. Affected versions pontedilana/php-weasyprint…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-x8g9-h984-pc36
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-49359 Advisory: PhpWeasyPrint vulnerable to SSRF and local file disclosure via the attachment option IDs: CVE-2026-49359, GHSA-x8g9-h984-pc36 Record: https://patchnext.com/advisories/cve-2026-49359 (revision 1, source checked 26 Oct 2026, 14:49 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: pontedilana/php-weasyprint 2.6.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist pontedilana/php-weasyprint: affected <= 2.5.1; fixed in 2.6.0 ## Suggested inspection (read-only) - Packagist pontedilana/php-weasyprint: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on pontedilana/php-weasyprint. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-x8g9-h984-pc36 (GitHub-reviewed advisory GHSA-x8g9-h984-pc36 lists affected ranges: Packagist pontedilana/php-weasyprint >=0 <=2.5.1) Commands are suggestions: review each one before running it.
Loading voting…