PhpWeasyPrint vulnerable to arbitrary file deletion at shutdown via public $temporaryFiles
CVE-2026-49358GHSA-5g9f-cwwg-4p8g
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (pontedilana/php-weasyprint 2.6.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist pontedilana/php-weasyprint
- Affected
- <= 2.5.1
- Fixed in
- 2.6.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-5g9f-cwwg-4p8g lists affected ranges: Packagist pontedilana/php-weasyprint >=0 <=2.5.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 3.0 · CVSS:3.1/AV:L/AC:H/PR:H/UI:N/S:U/C:N/I:L/A:L
- EPSS
- CVE-2026-49358: 0.17% estimated exploitation activity in the next 30 days; percentile 5.83 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary AbstractGenerator::$temporaryFiles is a public array, and removeTemporaryFiles() — invoked from destruct() and from a registered shutdown function — calls unlink() on every entry without verifying that the path is contained within the temporary folder. Any code holding a reference to a generator instance can push an arbitrary path into the array and have it deleted on script shutdown. This mirrors the KnpLabs/snappy issue GHSA-87qc-37cw-84h4, patched in snappy 1.7.2. Affected versions pontedilana/php-weasyprint versions <= 2.5.1. Patched in: 2.6.0. Vulnerable code src/AbstractGenerator.php: No path-containment check: whatever path is present in $temporaryFiles at shutdown is unlinked. Proof of concept Impact - Arbitrary file deletion bound to script shutdown, scoped to the privileges of the PHP process user. - Not directly exploitable on its own (the attacker already needs to influence the property in the same request). The risk is amplification: chained with a separate…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-5g9f-cwwg-4p8g
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-49358 Advisory: PhpWeasyPrint vulnerable to arbitrary file deletion at shutdown via public $temporaryFiles IDs: CVE-2026-49358, GHSA-5g9f-cwwg-4p8g Record: https://patchnext.com/advisories/cve-2026-49358 (revision 1, source checked 26 Oct 2026, 14:49 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 3.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: pontedilana/php-weasyprint 2.6.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist pontedilana/php-weasyprint: affected <= 2.5.1; fixed in 2.6.0 ## Suggested inspection (read-only) - Packagist pontedilana/php-weasyprint: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on pontedilana/php-weasyprint. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-5g9f-cwwg-4p8g (GitHub-reviewed advisory GHSA-5g9f-cwwg-4p8g lists affected ranges: Packagist pontedilana/php-weasyprint >=0 <=2.5.1) Commands are suggestions: review each one before running it.
Loading voting…