Skip to content

← Actionable
High, CVSS 8.8amended

Streamable HTTP mode exposes LINE Desktop read/send tools without MCP authentication

CVE-2026-49357GHSA-4hf8-5mjm-rfgq

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (line-desktop-mcp 1.1.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.8 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:L/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-49357: 0.56% estimated exploitation activity in the next 30 days; percentile 46.94 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Streamable HTTP mode exposes LINE Desktop read/send tools without MCP authentication Summary line-desktop-mcp supports a --http-mode Streamable HTTP transport for use with clients such as n8n. In this mode the server binds to 0.0.0.0 and exposes the MCP /mcp endpoint without an MCP-layer authentication check. Any network client that can reach the port can initialize a session, list tools, and call tools that read LINE Desktop chat history or send LINE messages through the already logged-in desktop application. This is High for deployments where the HTTP port is reachable beyond the local host, because the server acts with the user authority of the logged-in LINE Desktop session. It is lower if the listener is strictly firewalled to trusted local clients. Affected version Repository: dtwang/line-desktop-mcp Current source checked: fbed0d2d3048e63f48a356a1267ed8ec5e78f3ae on main, committed 2026-05-14. Published npm package checked: line-desktop-mcp@1.1.1. Source evidence README.md…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-4hf8-5mjm-rfgq

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-4hf8-5mjm-rfgq

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-49357

Advisory: Streamable HTTP mode exposes LINE Desktop read/send tools without MCP authentication
IDs: CVE-2026-49357, GHSA-4hf8-5mjm-rfgq
Record: https://patchnext.com/advisories/cve-2026-49357 (revision 3, source checked 26 Oct 2026, 12:56 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: line-desktop-mcp 1.1.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm line-desktop-mcp: affected <= 1.1.1; fixed in 1.1.2

## Suggested inspection (read-only)
- `npm ls line-desktop-mcp --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on line-desktop-mcp.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-4hf8-5mjm-rfgq (OSV record GHSA-4hf8-5mjm-rfgq lists affected ranges: npm line-desktop-mcp >=0 <1.1.2 (fixed))
- Verified: https://github.com/advisories/GHSA-4hf8-5mjm-rfgq (GitHub-reviewed advisory GHSA-4hf8-5mjm-rfgq lists affected ranges: npm line-desktop-mcp >=0 <=1.1.1)

Commands are suggestions: review each one before running it.

Loading voting…