Skip to content

← Actionable
Low, CVSS 3.2

@babel/core: Arbitrary File Read via sourceMappingURL Comment

CVE-2026-49356GHSA-4x5r-pxfx-6jf8

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@babel/core 8.0.0-rc.6, 7.29.6), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm @babel/core

    Affected
    >= 8.0.0-alpha.0, < 8.0.0-rc.6< 7.29.6
    Fixed in
    8.0.0-rc.6, 7.29.6

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
3.2 · CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:C/C:L/I:N/A:N
EPSS
  • CVE-2026-49356: 0.15% estimated exploitation activity in the next 30 days; percentile 4.35 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Using `@babel/core` to compile maliciously crafted code can allow ab attacker to read any source map from the system that is running Babel, if these conditions are _all_ true: - the attacker controls the input source code - the attacker can read the output source code - the attacker knows the path of the source map file that they want to read Users that only compile trusted code are not impacted.

Patches The vulnerability has been fixed in `@babel/core@7.29.6` and `@babel/core@8.0.0-rc.6`.

Workarounds Callers can mitigate the issue without upgrading by setting `inputSourceMap: false` in their Babel options. Callers can also manually extract the `#sourceMappingURL` comment from the input source code, validate whether the source map that it links to is allowed to be read, and if it is pass an object to `inputSourceMap` (passing `false` when it's not).

Credits Thanks Teodor-Cristian Radoi for reporting the…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from osv record GHSA-4x5r-pxfx-6jf8

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-49356

Advisory: @babel/core: Arbitrary File Read via sourceMappingURL Comment
IDs: CVE-2026-49356, GHSA-4x5r-pxfx-6jf8
Record: https://patchnext.com/advisories/cve-2026-49356 (revision 1, source checked 24 Oct 2026, 04:13 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 3.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @babel/core 8.0.0-rc.6, 7.29.6. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @babel/core: affected >= 8.0.0-alpha.0, < 8.0.0-rc.6; < 7.29.6; fixed in 8.0.0-rc.6, 7.29.6

## Suggested inspection (read-only)
- `npm ls @babel/core --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @babel/core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-4x5r-pxfx-6jf8 (OSV record GHSA-4x5r-pxfx-6jf8 lists affected ranges: npm @babel/core >=8.0.0-alpha.0 =0 <7.29.6 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…