9router's Hardcoded Default fallback JWT Secret Allows Authentication Bypass
CVE-2026-49352GHSA-jphh-m39h-6gwx
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (9router 0.4.45), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm 9router
- Affected
- >= 0.2.21, <= 0.4.41
- Fixed in
- 0.4.45
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-jphh-m39h-6gwx lists affected ranges: npm 9router >=0.2.21 <=0.4.41
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-jphh-m39h-6gwx lists affected ranges: npm 9router >=0.2.21 <0.4.45 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2026-49352: 0.60% estimated exploitation activity in the next 30 days; percentile 48.80 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary 9router uses a publicly known hardcoded string "9router-default-secret-change-me" as the fallback of JWT secret for all Dashboard session JWTs when the JWTSECRET environment variable is not set. Because this secret is committed in the public repository and unchanged across all releases, any unauthenticated remote attacker can forge a valid authtoken cookie and gain full access to dashboard and api (If JWTSECRET is not set on server) . This vulnerable affected so many public 9router server Details | Versions | File | Note | |---|---|---| | = 0.2.21, <= 0.4.30 | src/app/api/auth/login/route.js + src/middleware.js | Introduced in commit 23cfb19 | | = 0.4.31, <= 0.4.41 | src/lib/auth/dashboardSession.js | Relocated by OIDC refactor c3d91b0, secret unchanged | Vulnerable Code v0.2.21 – v0.4.30 — src/app/api/auth/login/route.js and src/middleware.js: v0.4.31 – v0.4.41 (current) — src/lib/auth/dashboardSession.js (centralized via OIDC refactor, commit c3d91b0): The fallback string…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-jphh-m39h-6gwx
- Revision 2 · amended ·
Amended from osv record GHSA-jphh-m39h-6gwx
- Revision 1 · created ·
Published from ghsa record GHSA-jphh-m39h-6gwx
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-49352 Advisory: 9router's Hardcoded Default fallback JWT Secret Allows Authentication Bypass IDs: CVE-2026-49352, GHSA-jphh-m39h-6gwx Record: https://patchnext.com/advisories/cve-2026-49352 (revision 3, source checked 26 Oct 2026, 12:56 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: 9router 0.4.45. A vendor fix does not mean a deployment is fixed. ## Affected components - npm 9router: affected >= 0.2.21, <= 0.4.41; fixed in 0.4.45 ## Suggested inspection (read-only) - `npm ls 9router --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on 9router. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-jphh-m39h-6gwx (GitHub-reviewed advisory GHSA-jphh-m39h-6gwx lists affected ranges: npm 9router >=0.2.21 <=0.4.41) - Verified: https://osv.dev/vulnerability/GHSA-jphh-m39h-6gwx (OSV record GHSA-jphh-m39h-6gwx lists affected ranges: npm 9router >=0.2.21 <0.4.45 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…