Skip to content

← Actionable
High, CVSS 8.1amended

Apache Airflow Google provider allows path traversal through GCS object names

CVE-2026-49297GHSA-v3mh-27qj-w836

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (apache-airflow-providers-google 22.2.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.1 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H
EPSS
  • CVE-2026-49297: 0.99% estimated exploitation activity in the next 30 days; percentile 62.67 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Apache Airflow's Google provider operators GCSToSFTPOperator and GCSTimeSpanFileTransformOperator joined GCS object names returned by the bucket listing API directly to a destination filesystem path without normalisation or containment check. A user with write access to the source GCS bucket (typically a different trust principal than the DAG author — partner uploads, ingest-only service accounts, public-data buckets) could create an object whose name contains .. segments and cause the DAG run to write the downloaded blob outside the configured destination (the SFTP destinationpath for GCSToSFTPOperator; the worker-local temp directory for GCSTimeSpanFileTransformOperator), enabling overwrite of arbitrary files on the SFTP server or the worker host. Affects deployments that ingest from buckets writable by less-trusted principals. Users are advised to upgrade to apache-airflow-providers-google 22.2.1 or later.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-v3mh-27qj-w836

  2. Revision 1 · created ·

    Published from osv record GHSA-v3mh-27qj-w836

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-49297

Advisory: Apache Airflow Google provider allows path traversal through GCS object names
IDs: CVE-2026-49297, GHSA-v3mh-27qj-w836
Record: https://patchnext.com/advisories/cve-2026-49297 (revision 2, source checked 26 Oct 2026, 13:51 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: apache-airflow-providers-google 22.2.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI apache-airflow-providers-google: affected < 22.2.1; fixed in 22.2.1

## Suggested inspection (read-only)
- `python -m pip show apache-airflow-providers-google`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on apache-airflow-providers-google.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-v3mh-27qj-w836 (OSV record GHSA-v3mh-27qj-w836 lists affected ranges: PyPI apache-airflow-providers-google >=0 <22.2.1 (fixed))
- Verified: https://github.com/advisories/GHSA-v3mh-27qj-w836 (GitHub-reviewed advisory GHSA-v3mh-27qj-w836 lists affected ranges: PyPI apache-airflow-providers-google >=0 <22.2.1)

Commands are suggestions: review each one before running it.

Loading voting…