SimpleSAMLphp has Possible DoS via XPath Transform
CVE-2026-49289GHSA-5cjr-mxj5-wmrx
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (simplesamlphp/saml2-legacy 4.20.3, 4.19.3; simplesamlphp/saml2 4.20.3, 4.19.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist simplesamlphp/saml2-legacy
- Affected
- >= 4.20.0, <= 4.20.2<= 4.19.2
- Fixed in
- 4.20.3, 4.19.3
Packagist simplesamlphp/saml2
- Affected
- >= 4.20.0, <= 4.20.2<= 4.19.2
- Fixed in
- 4.20.3, 4.19.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-5cjr-mxj5-wmrx lists affected ranges: Packagist simplesamlphp/saml2 >=4.20.0 =0 =4.20.0 =0 <=4.19.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2026-49289: 0.78% estimated exploitation activity in the next 30 days; percentile 56.10 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary This library turned out to be vulnerable to Denial-of-Service attacks using XPath transforms. A mitigation has been put in place to restrict the number of transforms and to restrict transforms to only the transform-algorithms mentioned in the SAML 2.0 Core Specifications (and specifically refuse XPath transforms). Impact An attacker is able to send specially crafted messages to any entity relying on SimpleSAMLphp (or directly on this SAML2-library) to be able to perform a Denial-of-Service attack.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-5cjr-mxj5-wmrx
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-49289 Advisory: SimpleSAMLphp has Possible DoS via XPath Transform IDs: CVE-2026-49289, GHSA-5cjr-mxj5-wmrx Record: https://patchnext.com/advisories/cve-2026-49289 (revision 1, source checked 26 Oct 2026, 14:50 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: simplesamlphp/saml2-legacy 4.20.3, 4.19.3; simplesamlphp/saml2 4.20.3, 4.19.3. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist simplesamlphp/saml2-legacy: affected >= 4.20.0, <= 4.20.2; <= 4.19.2; fixed in 4.20.3, 4.19.3 - Packagist simplesamlphp/saml2: affected >= 4.20.0, <= 4.20.2; <= 4.19.2; fixed in 4.20.3, 4.19.3 ## Suggested inspection (read-only) - Packagist simplesamlphp/saml2-legacy: check the installed version with your package manager. - Packagist simplesamlphp/saml2: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on simplesamlphp/saml2-legacy, simplesamlphp/saml2. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-5cjr-mxj5-wmrx (GitHub-reviewed advisory GHSA-5cjr-mxj5-wmrx lists affected ranges: Packagist simplesamlphp/saml2 >=4.20.0 =0 =4.20.0 =0 <=4.19.2) Commands are suggestions: review each one before running it.
Loading voting…