Skip to content

← Actionable
High, CVSS 7.4

Statamic CMS's unsafe method invocation via collection sorting allows data destruction

CVE-2026-49287GHSA-m92m-r54r-x8r2

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (statamic/cms 6.20.0, 5.73.23), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist statamic/cms

    Affected
    < 5.73.23>= 6.0.0, < 6.20.0
    Fixed in
    5.73.23, 6.20.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.4 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:H
EPSS
  • CVE-2026-49287: 0.46% estimated exploitation activity in the next 30 days; percentile 39.71 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The fix for GHSA-4jjr-vmv7-wh4w was incomplete. It addressed the issue in the query builder, but the same protection was not applied to in-memory collection sorting. Manipulating sort parameters could result in the loss of content and assets. This requires a front-end template that passes request input into a tag's sort parameter. It is not exploitable by default — a template would need to be explicitly set up to sort by a visitor-controlled value. Patches This has been fixed in 5.73.23 and 6.20.0.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-m92m-r54r-x8r2

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-49287

Advisory: Statamic CMS's unsafe method invocation via collection sorting allows data destruction
IDs: CVE-2026-49287, GHSA-m92m-r54r-x8r2
Record: https://patchnext.com/advisories/cve-2026-49287 (revision 1, source checked 26 Oct 2026, 14:49 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: statamic/cms 6.20.0, 5.73.23. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist statamic/cms: affected < 5.73.23; >= 6.0.0, < 6.20.0; fixed in 5.73.23, 6.20.0

## Suggested inspection (read-only)
- Packagist statamic/cms: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on statamic/cms.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-m92m-r54r-x8r2 (GitHub-reviewed advisory GHSA-m92m-r54r-x8r2 lists affected ranges: Packagist statamic/cms >=0 =6.0.0 <6.20.0)

Commands are suggestions: review each one before running it.

Loading voting…