Skip to content

← Actionable
High, CVSS 8.7

SimpleSAMLphp HTTP-Artifact TLS validator confusion allows cross-IdP authentication bypass

CVE-2026-49283GHSA-6929-8p9f-26jx

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (simplesamlphp/saml2-legacy 4.20.2, 4.19.3; simplesamlphp/saml2 6.2.1, 5.0.6, 4.20.2, 4.19.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist simplesamlphp/saml2-legacy

    Affected
    >= 4.20.0, < 4.20.2< 4.19.3
    Fixed in
    4.20.2, 4.19.3
  • Packagist simplesamlphp/saml2

    Affected
    >= 6.0.0, < 6.2.1>= 5.0.0, < 5.0.6>= 4.20.0, < 4.20.2< 4.19.3
    Fixed in
    6.2.1, 5.0.6, 4.20.2, 4.19.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.7 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:N
EPSS
  • CVE-2026-49283: 0.47% estimated exploitation activity in the next 30 days; percentile 40.86 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary SimpleSAMLphp's HTTP-Artifact receive path can treat an unsigned embedded SAML Response as cryptographically valid for the wrong IdP. In the HTTPArtifact::receive() flow, the SOAP ArtifactResponse receives a TLS-based validator from SOAPClient::addSSLValidator(). The embedded SAML Response then receives a validator that delegates signature validation to that outer ArtifactResponse. Later, the SP validates the embedded Response against metadata selected from the embedded response issuer, not necessarily the artifact issuer. The critical issue is that SOAPClient::validateSSL() returns normally when the TLS public key does not match the key currently being validated. SAML2\Message::validate() treats any validator call that does not throw an exception as successful. As a result, an ArtifactResponse obtained from one IdP can validate an unsigned embedded SAML Response that claims to be issued by a different IdP. In a multi-IdP/federation deployment where a malicious or lower-trust…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-6929-8p9f-26jx

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-49283

Advisory: SimpleSAMLphp HTTP-Artifact TLS validator confusion allows cross-IdP authentication bypass
IDs: CVE-2026-49283, GHSA-6929-8p9f-26jx
Record: https://patchnext.com/advisories/cve-2026-49283 (revision 1, source checked 26 Oct 2026, 14:50 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: simplesamlphp/saml2-legacy 4.20.2, 4.19.3; simplesamlphp/saml2 6.2.1, 5.0.6, 4.20.2, 4.19.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist simplesamlphp/saml2-legacy: affected >= 4.20.0, < 4.20.2; < 4.19.3; fixed in 4.20.2, 4.19.3
- Packagist simplesamlphp/saml2: affected >= 6.0.0, < 6.2.1; >= 5.0.0, < 5.0.6; >= 4.20.0, < 4.20.2; < 4.19.3; fixed in 6.2.1, 5.0.6, 4.20.2, 4.19.3

## Suggested inspection (read-only)
- Packagist simplesamlphp/saml2-legacy: check the installed version with your package manager.
- Packagist simplesamlphp/saml2: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on simplesamlphp/saml2-legacy, simplesamlphp/saml2.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-6929-8p9f-26jx (GitHub-reviewed advisory GHSA-6929-8p9f-26jx lists affected ranges: Packagist simplesamlphp/saml2 >=6.0.0 =5.0.0 =4.20.0 =0 =4.20.0 =0 <4.19.3)

Commands are suggestions: review each one before running it.

Loading voting…