Skip to content

← Actionable
High, CVSS 7.4

Kirby: Self cross-site scripting (self-XSS) in the writer field

CVE-2026-49276GHSA-rhj6-r49h-5932

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (getkirby/cms 5.4.4, 4.9.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist getkirby/cms

    Affected
    <= 4.9.3>= 5.0.0-alpha.1, <= 5.4.3
    Fixed in
    4.9.4, 5.4.4

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.4 · CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:A/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-49276: 0.43% estimated exploitation activity in the next 30 days; percentile 37.56 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

TL;DR This vulnerability affects Kirby sites that use the writer field in any blueprint. It was possible to include a scripting link as the target of a link (or email link). This link target would then be clickable by the user who entered it. A successful attack commonly requires knowledge of the content structure by the attacker as well as social engineering of a user with access to the Panel. The attack cannot be automated. In Kirby's default configuration, the vulnerability is limited to self-XSS and cannot directly affect other users or visitors of the site. Panel plugins that are directly using the <k-writer component may also be affected by stored XSS if they don't sanitize the resulting HTML before saving it to the content. This vulnerability is of high severity for affected sites. ---- Introduction Cross-site scripting (XSS) is a type of vulnerability that allows attackers to execute any kind of JavaScript code inside the Panel session of the same or other users. In the…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-rhj6-r49h-5932

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-49276

Advisory: Kirby: Self cross-site scripting (self-XSS) in the writer field
IDs: CVE-2026-49276, GHSA-rhj6-r49h-5932
Record: https://patchnext.com/advisories/cve-2026-49276 (revision 1, source checked 26 Oct 2026, 14:49 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: getkirby/cms 5.4.4, 4.9.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist getkirby/cms: affected <= 4.9.3; >= 5.0.0-alpha.1, <= 5.4.3; fixed in 4.9.4, 5.4.4

## Suggested inspection (read-only)
- Packagist getkirby/cms: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on getkirby/cms.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-rhj6-r49h-5932 (GitHub-reviewed advisory GHSA-rhj6-r49h-5932 lists affected ranges: Packagist getkirby/cms >=0 =5.0.0-alpha.1 <=5.4.3)

Commands are suggestions: review each one before running it.

Loading voting…