MantisBT: Remote Code Execution via eval() Class Hoisting in adm_config_set.php
CVE-2026-49273GHSA-v84x-qvhg-f36r
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (mantisbt/mantisbt 2.28.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist mantisbt/mantisbt
- Affected
- >= 1.3.0, <= 2.28.3
- Fixed in
- 2.28.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-v84x-qvhg-f36r lists affected ranges: Packagist mantisbt/mantisbt >=1.3.0 <=2.28.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.6 · CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
MantisBT 2.28.3 and earlier contains a remote code execution vulnerability in the admin "Manage Configuration" feature (admconfigset.php). When setting a configuration value with a non-string type (integer, float, complex), the value is passed through ConfigParser - Tokenizer, which calls eval() with a return; prefix intended to prevent code execution. However, PHP hoists function and class declarations at compile time, even past a return statement. An attacker can define a class in the eval()'d code that hijacks a class loaded later via PHP's autoloader, achieving arbitrary code execution. This vulnerability requires administrator access to the web UI (admconfigset.php). The REST API's ConfigsSetCommand does NOT use Tokenizer/eval() and is not affected. Impact - Remote code execution as the web server user (www-data) from an authenticated administrator session Patches - https://github.com/mantisbt/mantisbt/commit/78c0af63d1fe0118004744cab21ca3bf2cea0f5c Workarounds None. Resources -…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-v84x-qvhg-f36r
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-49273 Advisory: MantisBT: Remote Code Execution via eval() Class Hoisting in adm_config_set.php IDs: CVE-2026-49273, GHSA-v84x-qvhg-f36r Record: https://patchnext.com/advisories/cve-2026-49273 (revision 1, source checked 26 Oct 2026, 14:50 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: mantisbt/mantisbt 2.28.4. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist mantisbt/mantisbt: affected >= 1.3.0, <= 2.28.3; fixed in 2.28.4 ## Suggested inspection (read-only) - Packagist mantisbt/mantisbt: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on mantisbt/mantisbt. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-v84x-qvhg-f36r (GitHub-reviewed advisory GHSA-v84x-qvhg-f36r lists affected ranges: Packagist mantisbt/mantisbt >=1.3.0 <=2.28.3) Commands are suggestions: review each one before running it.
Loading voting…