Apache ActiveMQ Broker, Apache ActiveMQ, Apache ActiveMQ All have an Exposure of Sensitive Information Through Metadata vulnerability
CVE-2026-49270GHSA-hf52-78x8-6w3w
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.activemq:activemq-broker 6.2.6, 5.19.7; org.apache.activemq:apache-activemq 6.2.6, 5.19.7; org.apache.activemq:activemq-all 6.2.6, 5.19.7), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.activemq:activemq-broker
- Affected
- < 5.19.7>= 6.0.0, < 6.2.6
- Fixed in
- 6.2.6, 5.19.7
Maven org.apache.activemq:apache-activemq
- Affected
- < 5.19.7>= 6.0.0, < 6.2.6
- Fixed in
- 6.2.6, 5.19.7
Maven org.apache.activemq:activemq-all
- Affected
- < 5.19.7>= 6.0.0, < 6.2.6
- Fixed in
- 6.2.6, 5.19.7
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-hf52-78x8-6w3w lists affected ranges: Maven org.apache.activemq:apache-activemq >=0 =6.0.0 =0 =6.0.0 =0 =6.0.0 <6.2.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.9 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2026-49270: 0.37% estimated exploitation activity in the next 30 days; percentile 30.80 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Exposure of Sensitive Information Through Metadata vulnerability in Apache ActiveMQ Broker, Apache ActiveMQ, Apache ActiveMQ All. Brokers that are configured with a network connector with syncDurableSubs set to true, are vulnerable to an unauthenticated attacker who can receive a list of all durable topic subscriptions in the broker, including client identifiers, subscription names, topic destinations, and JMS selector expressions, by sending a BrokerInfo command. The broker incorrectly responds without first ensuring the connection is authenticated. This issue affects Apache ActiveMQ Broker: before 5.19.7, from 6.0.0 before 6.2.6; Apache ActiveMQ: before 5.19.7, from 6.0.0 before 6.2.6; Apache ActiveMQ All: before 5.19.7, from 6.0.0 before 6.2.6. Users are recommended to upgrade to version 6.2.6 or 5.19.7, which fixes the issue.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-hf52-78x8-6w3w
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-49270 Advisory: Apache ActiveMQ Broker, Apache ActiveMQ, Apache ActiveMQ All have an Exposure of Sensitive Information Through Metadata vulnerability IDs: CVE-2026-49270, GHSA-hf52-78x8-6w3w Record: https://patchnext.com/advisories/cve-2026-49270 (revision 1, source checked 26 Oct 2026, 16:54 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.apache.activemq:activemq-broker 6.2.6, 5.19.7; org.apache.activemq:apache-activemq 6.2.6, 5.19.7; org.apache.activemq:activemq-all 6.2.6, 5.19.7. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.activemq:activemq-broker: affected < 5.19.7; >= 6.0.0, < 6.2.6; fixed in 6.2.6, 5.19.7 - Maven org.apache.activemq:apache-activemq: affected < 5.19.7; >= 6.0.0, < 6.2.6; fixed in 6.2.6, 5.19.7 - Maven org.apache.activemq:activemq-all: affected < 5.19.7; >= 6.0.0, < 6.2.6; fixed in 6.2.6, 5.19.7 ## Suggested inspection (read-only) - Maven org.apache.activemq:activemq-broker: check the installed version with your package manager. - Maven org.apache.activemq:apache-activemq: check the installed version with your package manager. - Maven org.apache.activemq:activemq-all: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.activemq:activemq-broker, org.apache.activemq:apache-activemq, org.apache.activemq:activemq-all. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-hf52-78x8-6w3w (GitHub-reviewed advisory GHSA-hf52-78x8-6w3w lists affected ranges: Maven org.apache.activemq:apache-activemq >=0 =6.0.0 =0 =6.0.0 =0 =6.0.0 <6.2.6) Commands are suggestions: review each one before running it.
Loading voting…