Apache Airflow has no certificate validation on SMTP STARTTLS connections
CVE-2026-49267GHSA-799x-qp47-8qwq
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (apache-airflow 3.2.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI apache-airflow
- Affected
- >= 2.0.0, < 3.2.2
- Fixed in
- 3.2.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-799x-qp47-8qwq lists affected ranges: PyPI apache-airflow >=2.0.0 <3.2.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-799x-qp47-8qwq lists affected ranges: PyPI apache-airflow >=2.0.0 <3.2.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.9 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2026-49267: 0.18% estimated exploitation activity in the next 30 days; percentile 8.14 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Apache Airflow's EmailOperator and the underlying airflow.utils.email helpers established SMTP STARTTLS connections without verifying the remote certificate when the deployment used [email] smtpstarttls=True without [email] smtpssl. An attacker positioned between the worker and the configured SMTP server (network MITM — typical hostile-network attack-surface for environments where the SMTP relay sits outside the worker's trust boundary) could present a self-signed certificate, have the worker complete the STARTTLS handshake silently, and capture the SMTP AUTH credentials and message contents the worker forwarded. This CVE covers the core apache-airflow side of the same root cause already covered for the SMTP provider by CVE-2026-41016 (published 2026-04-27, covering apache-airflow-providers-smtp). Users who already applied the SMTP-provider fix from CVE-2026-41016 should additionally upgrade apache-airflow to 3.2.2 or later to cover the core-side path through airflow.utils.email.…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-799x-qp47-8qwq
- Revision 1 · created ·
Published from osv record GHSA-799x-qp47-8qwq
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-49267 Advisory: Apache Airflow has no certificate validation on SMTP STARTTLS connections IDs: CVE-2026-49267, GHSA-799x-qp47-8qwq Record: https://patchnext.com/advisories/cve-2026-49267 (revision 2, source checked 26 Oct 2026, 13:46 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: apache-airflow 3.2.2. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI apache-airflow: affected >= 2.0.0, < 3.2.2; fixed in 3.2.2 ## Suggested inspection (read-only) - `python -m pip show apache-airflow`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on apache-airflow. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-799x-qp47-8qwq (OSV record GHSA-799x-qp47-8qwq lists affected ranges: PyPI apache-airflow >=2.0.0 <3.2.2 (fixed)) - Verified: https://github.com/advisories/GHSA-799x-qp47-8qwq (GitHub-reviewed advisory GHSA-799x-qp47-8qwq lists affected ranges: PyPI apache-airflow >=2.0.0 <3.2.2) Commands are suggestions: review each one before running it.
Loading voting…