Skip to content

← Actionable
Medium, CVSS 6.8amended

Oauthlib: Timing Attack Vulnerability in PKCE code_verifier Comparison (CWE-208)

CVE-2026-49265GHSA-xpv3-w29h-x7cv

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (oauthlib 4.0.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI oauthlib

    Affected
    >= 3.0.0, < 4.0.0
    Fixed in
    4.0.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.8 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:N
EPSS
  • CVE-2026-49265: 0.24% estimated exploitation activity in the next 30 days; percentile 15.48 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A timing side-channel vulnerability exists in the PKCE (RFC 7636) implementation of the Authorization Code Grant flow. The codechallengemethodplain function uses Python's standard == operator for string comparison instead of a constant-time comparison function, potentially allowing timing-based attacks. Affected Component - File: oauthlib/oauth2/rfc6749/granttypes/authorizationcode.py - Functions: codechallengemethodplain, codechallengemethods256 - Vulnerability Type: CWE-208 (Observable Timing Discrepancy) Technical Details Python's == operator uses short-circuit evaluation when comparing strings: 1. Returns False immediately if lengths differ 2. Compares characters left-to-right, stopping at first mismatch This means comparison time varies linearly with the length of the common prefix between the attacker-supplied verifier and the stored challenge, creating a measurable timing oracle. Proof of Concept Tested locally against oauthlib source (network jitter eliminated to…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-xpv3-w29h-x7cv

  2. Revision 2 · amended ·

    Amended from osv record GHSA-xpv3-w29h-x7cv

  3. Revision 1 · created ·

    Published from ghsa record GHSA-xpv3-w29h-x7cv

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-49265

Advisory: Oauthlib: Timing Attack Vulnerability in PKCE code_verifier Comparison (CWE-208)
IDs: CVE-2026-49265, GHSA-xpv3-w29h-x7cv
Record: https://patchnext.com/advisories/cve-2026-49265 (revision 3, source checked 26 Oct 2026, 13:55 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: oauthlib 4.0.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI oauthlib: affected >= 3.0.0, < 4.0.0; fixed in 4.0.0

## Suggested inspection (read-only)
- `python -m pip show oauthlib`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on oauthlib.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-xpv3-w29h-x7cv (GitHub-reviewed advisory GHSA-xpv3-w29h-x7cv lists affected ranges: PyPI oauthlib >=3.0.0 <4.0.0)
- Verified: https://osv.dev/vulnerability/GHSA-xpv3-w29h-x7cv (OSV record GHSA-xpv3-w29h-x7cv lists affected ranges: PyPI oauthlib >=3.0.0 <4.0.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…