Skip to content

← Actionable
Critical, CVSS 10.0amended

mcp-pinot: Unauthenticated tool invocation via default oauth_enabled=False + host 0.0.0.0 bind

CVE-2026-49257GHSA-73cv-556c-w3g6

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (mcp-pinot-server 3.1.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
10.0 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
EPSS
  • CVE-2026-49257: 0.62% estimated exploitation activity in the next 30 days; percentile 49.84 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Resolution Fixed in v3.1.0, released 2026-05-25. The fix was merged in PR #95 at commit 1c7d3f9. The fix changes the default HTTP bind host to 127.0.0.1, refuses non-loopback HTTP/HTTPS exposure unless OAuth is enabled, makes Helm exposure opt-in and OAuth-gated, and adds parser-backed single-statement read-only validation for read-query. CVSS evaluation Reviewed on 2026-05-25. The advisory remains Critical with CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H = 10.0. Rationale: | Metric | Value | Reason | |---|---|---| | AV | Network | The default HTTP server bound to 0.0.0.0:8080 and accepted remote HTTP requests. | | AC | Low | Exploitation required only a direct MCP tool call. | | PR | None | OAuth was disabled by default. | | UI | None | No user interaction was required. | | S | Changed | The vulnerable MCP server used its server-side credentials to act on the separate Pinot cluster security boundary. | | C | High | Unauthenticated callers could read table data and cluster metadata…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-73cv-556c-w3g6

  2. Revision 2 · amended ·

    Amended from osv record GHSA-73cv-556c-w3g6

  3. Revision 1 · created ·

    Published from ghsa record GHSA-73cv-556c-w3g6

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-49257

Advisory: mcp-pinot: Unauthenticated tool invocation via default oauth_enabled=False + host 0.0.0.0 bind
IDs: CVE-2026-49257, GHSA-73cv-556c-w3g6
Record: https://patchnext.com/advisories/cve-2026-49257 (revision 3, source checked 26 Oct 2026, 13:46 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 10.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: mcp-pinot-server 3.1.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI mcp-pinot-server: affected <= 3.0.1; fixed in 3.1.0

## Suggested inspection (read-only)
- `python -m pip show mcp-pinot-server`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on mcp-pinot-server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-73cv-556c-w3g6 (GitHub-reviewed advisory GHSA-73cv-556c-w3g6 lists affected ranges: PyPI mcp-pinot-server >=0 <=3.0.1)
- Verified: https://osv.dev/vulnerability/GHSA-73cv-556c-w3g6 (OSV record GHSA-73cv-556c-w3g6 lists affected ranges: PyPI mcp-pinot-server >=0 <3.1.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…