Skip to content

← Actionable
High, CVSS 8.8amended

electerm has Command Injection in File System Operations (rmrf, mv, cp)

CVE-2026-49255GHSA-v5ff-xmfp-p245

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (electerm 3.11.11), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm electerm

    Affected
    <= 3.11.0
    Fixed in
    3.11.11

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-49255: 0.79% estimated exploitation activity in the next 30 days; percentile 56.31 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact A command injection vulnerability exists in electerm's file system operations (rmrf, mv, cp) in src/app/lib/fs.js. These functions construct shell commands by interpolating file paths directly into command strings without escaping shell metacharacters. Vulnerable functions: - rmrf() - Uses rm -rf "${path}" (double quotes, vulnerable to " injection) - mv() - Uses mv '${from}' '${to}' (single quotes, vulnerable to ' injection) - cp() - Uses cp -r "${from}" "${to}" (double quotes, vulnerable to " injection) Attack scenario: 1. Attacker controls a malicious SSH/SFTP server 2. Server lists files with shell metacharacters in names (e.g., file"$(touch /tmp/pwned)") 3. Victim connects to the server and performs file operations (remote-to-local transfer, rename on conflict, etc.) 4. The malicious filename is passed to rmrf(), mv(), or cp() without sanitization 5. Shell metacharacters break out of the quoted argument and execute arbitrary commands Impact includes: - Arbitrary command…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-v5ff-xmfp-p245

  2. Revision 1 · created ·

    Published from osv record GHSA-v5ff-xmfp-p245

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-49255

Advisory: electerm has Command Injection in File System Operations (rmrf, mv, cp)
IDs: CVE-2026-49255, GHSA-v5ff-xmfp-p245
Record: https://patchnext.com/advisories/cve-2026-49255 (revision 2, source checked 26 Oct 2026, 12:56 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: electerm 3.11.11. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm electerm: affected <= 3.11.0; fixed in 3.11.11

## Suggested inspection (read-only)
- `npm ls electerm --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on electerm.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-v5ff-xmfp-p245 (OSV record GHSA-v5ff-xmfp-p245 lists affected ranges: npm electerm >=0 <3.11.11 (fixed))
- Verified: https://github.com/advisories/GHSA-v5ff-xmfp-p245 (GitHub-reviewed advisory GHSA-v5ff-xmfp-p245 lists affected ranges: npm electerm >=0 <=3.11.0)

Commands are suggestions: review each one before running it.

Loading voting…