Dragonfly Manager OAuth provider client_secret disclosure via unauthenticated GET /api/v1/oauth
CVE-2026-49254GHSA-4q9j-6299-gxmr
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (d7y.io/dragonfly/v2 2.4.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- <= 2.4.3
- Fixed in
- 2.4.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-4q9j-6299-gxmr lists affected ranges: Go d7y.io/dragonfly/v2 >=0 <=2.4.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 2.9 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N/E:P · score source
- EPSS
- CVE-2026-49254: 0.48% estimated exploitation activity in the next 30 days; percentile 41.47 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The Dragonfly Manager exposes GET /api/v1/oauth and GET /api/v1/oauth/:id to unauthenticated clients. The response body deserializes the entire manager/models.Oauth struct, which includes the clientsecret field. Any network-reachable attacker can read the OAuth client secrets configured for github or google providers, defeating the confidentiality guarantee of those secrets and enabling subsequent abuse against the connected identity providers. Affected versions github.com/dragonflyoss/dragonfly <= v2.4.3 (and current main at commit 46a8f1e). The vulnerable wiring is present back to the introduction of OAuth GET handlers and was not addressed by GHSA-j8hf-cp34-g4j7 / CVE-2026-24124, whose remediation only added jwt + rbac middleware to the /jobs group. Privilege required Unauthenticated. The only precondition is that an administrator has registered at least one OAuth provider via POST /api/v1/oauth (a one-time setup for tenants that enable GitHub / Google sign-in). Vulnerable…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-4q9j-6299-gxmr
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-49254 Advisory: Dragonfly Manager OAuth provider client_secret disclosure via unauthenticated GET /api/v1/oauth IDs: CVE-2026-49254, GHSA-4q9j-6299-gxmr Record: https://patchnext.com/advisories/cve-2026-49254 (revision 1, source checked 26 Oct 2026, 15:24 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 2.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: d7y.io/dragonfly/v2 2.4.4. A vendor fix does not mean a deployment is fixed. ## Affected components - Go d7y.io/dragonfly/v2: affected <= 2.4.3; fixed in 2.4.4 ## Suggested inspection (read-only) - Go d7y.io/dragonfly/v2: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on d7y.io/dragonfly/v2. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-4q9j-6299-gxmr (GitHub-reviewed advisory GHSA-4q9j-6299-gxmr lists affected ranges: Go d7y.io/dragonfly/v2 >=0 <=2.4.3) Commands are suggestions: review each one before running it.
Loading voting…