Skip to content

← Actionable
High, CVSS 7.1amended

electerm has Path Traversal in Zmodem and Trzsz Download Filename Handling

CVE-2026-49253GHSA-38j7-23hf-9mhc

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (electerm 3.11.11), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm electerm

    Affected
    <= 3.11.0
    Fixed in
    3.11.11

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:L
EPSS
  • CVE-2026-49253: 0.44% estimated exploitation activity in the next 30 days; percentile 38.24 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact A path traversal vulnerability exists in the Zmodem and Trzsz file download handlers in electerm. When receiving files via Zmodem or Trzsz protocols, electerm uses the remote-supplied filename directly in path.join() with the user-selected download directory without sanitization. A malicious SSH server or remote shell process can send a specially crafted filename such as ../escaped.txt to escape the user-selected download directory and write files to arbitrary locations on the user's filesystem, subject to process permissions. Attack scenario: 1. User connects to a malicious SSH server 2. Attacker initiates a Zmodem or Trzsz file transfer 3. Attacker supplies a traversal filename (e.g., ../../.bashrc, ../escaped.txt) 4. User accepts the transfer and selects a download directory 5. File is written outside the selected directory, potentially overwriting sensitive files Affected components: - src/app/server/zmodem.js - prepareReceiveFile() at line 736 - src/app/server/trzsz.js -…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-38j7-23hf-9mhc

  2. Revision 1 · created ·

    Published from osv record GHSA-38j7-23hf-9mhc

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-49253

Advisory: electerm has Path Traversal in Zmodem and Trzsz Download Filename Handling
IDs: CVE-2026-49253, GHSA-38j7-23hf-9mhc
Record: https://patchnext.com/advisories/cve-2026-49253 (revision 2, source checked 26 Oct 2026, 12:56 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: electerm 3.11.11. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm electerm: affected <= 3.11.0; fixed in 3.11.11

## Suggested inspection (read-only)
- `npm ls electerm --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on electerm.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-38j7-23hf-9mhc (OSV record GHSA-38j7-23hf-9mhc lists affected ranges: npm electerm >=0 <3.11.11 (fixed))
- Verified: https://github.com/advisories/GHSA-38j7-23hf-9mhc (GitHub-reviewed advisory GHSA-38j7-23hf-9mhc lists affected ranges: npm electerm >=0 <=3.11.0)

Commands are suggestions: review each one before running it.

Loading voting…