deepstream is vulnerable to prototype pollution
CVE-2026-49252GHSA-9v98-6g37-x9g6
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@deepstream/server 10.0.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 10.0.5
- Fixed in
- 10.0.5
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-9v98-6g37-x9g6 lists affected ranges: npm @deepstream/server >=0 <10.0.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-9v98-6g37-x9g6 lists affected ranges: npm @deepstream/server >=0 <10.0.5 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.9 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:L
- EPSS
- CVE-2026-49252: 0.47% estimated exploitation activity in the next 30 days; percentile 40.70 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Prototype pollution in deepstream server v <=10.0.4. Potential privilege escalation from any authenticated user with write permission to any record. Patches Yes, upgrade to v10.0.5 Workarounds Filter out all messages containing the path proto, constructor, prototype, before they reach the server's message pipeline
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-9v98-6g37-x9g6
- Revision 2 · amended ·
Amended from osv record GHSA-9v98-6g37-x9g6
- Revision 1 · created ·
Published from ghsa record GHSA-9v98-6g37-x9g6
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-49252 Advisory: deepstream is vulnerable to prototype pollution IDs: CVE-2026-49252, GHSA-9v98-6g37-x9g6 Record: https://patchnext.com/advisories/cve-2026-49252 (revision 3, source checked 26 Oct 2026, 12:56 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @deepstream/server 10.0.5. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @deepstream/server: affected < 10.0.5; fixed in 10.0.5 ## Suggested inspection (read-only) - `npm ls @deepstream/server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @deepstream/server. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-9v98-6g37-x9g6 (GitHub-reviewed advisory GHSA-9v98-6g37-x9g6 lists affected ranges: npm @deepstream/server >=0 <10.0.5) - Verified: https://osv.dev/vulnerability/GHSA-9v98-6g37-x9g6 (OSV record GHSA-9v98-6g37-x9g6 lists affected ranges: npm @deepstream/server >=0 <10.0.5 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…