Skip to content

← Actionable
High, CVSS 8.3amended

@actual-app/sync-server: Disabled OpenID users keep access through existing session tokens

CVE-2026-49229GHSA-cq9c-6w48-qmfg

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@actual-app/sync-server 26.6.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:L
EPSS
  • CVE-2026-49229: 0.32% estimated exploitation activity in the next 30 days; percentile 25.10 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary In OpenID multi-user mode, disabling a user only blocks future OpenID login for that identity. Existing Actual session tokens for the disabled user remain valid, so the user can continue calling authenticated server endpoints after an administrator has disabled the account. Details The disabled-user check is present during OpenID login finalization. Existing users are only accepted when the matching row has enabled = 1, and a disabled row causes the OpenID grant to fail before a new session token is created. The shared session validation path does not perform the same enabled-user check. It accepts any existing token row that has not expired, then returns the session object to every route protected by validateSessionMiddleware. This means account disablement and session authorization diverge: The default token expiration setting is never, so this is not just a short race after disablement on default deployments. Admins can change a user's enabled state through the user update…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-cq9c-6w48-qmfg

  2. Revision 1 · created ·

    Published from osv record GHSA-cq9c-6w48-qmfg

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-49229

Advisory: @actual-app/sync-server: Disabled OpenID users keep access through existing session tokens
IDs: CVE-2026-49229, GHSA-cq9c-6w48-qmfg
Record: https://patchnext.com/advisories/cve-2026-49229 (revision 2, source checked 26 Oct 2026, 12:56 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @actual-app/sync-server 26.6.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @actual-app/sync-server: affected <= 26.5.2; fixed in 26.6.0

## Suggested inspection (read-only)
- `npm ls @actual-app/sync-server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @actual-app/sync-server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-cq9c-6w48-qmfg (OSV record GHSA-cq9c-6w48-qmfg lists affected ranges: npm @actual-app/sync-server >=0 <26.6.0 (fixed))
- Verified: https://github.com/advisories/GHSA-cq9c-6w48-qmfg (GitHub-reviewed advisory GHSA-cq9c-6w48-qmfg lists affected ranges: npm @actual-app/sync-server >=0 <=26.5.2)

Commands are suggestions: review each one before running it.

Loading voting…