Skip to content

← Actionable
Medium, CVSS 5.1

symfony/ux-autocomplete: XSS via unescaped AJAX response data

CVE-2026-49216GHSA-mwqm-4fw3-cjvr

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (symfony/ux-autocomplete 3.1.0, 2.36.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N · score source
EPSS
  • CVE-2026-49216: 0.31% estimated exploitation activity in the next 30 days; percentile 24.10 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Description The Stimulus controller shipped with symfony/ux-autocomplete renders AJAX response items into the dropdown by interpolating the text field directly into HTML template literals (<div${item[labelField]}</div) inside createAutocompleteWithRemoteData(). The value is parsed as HTML rather than text, so any markup contained in the AJAX response is executed by the browser. When the dropdown values are derived from user-supplied content, an attacker can craft a string that triggers stored XSS in the browser of any other user who later opens a page containing an autocomplete widget backed by the same data. Resolution The option and item renderers used in createAutocompleteWithRemoteData() now use TomSelect's escape helper to HTML-escape the value by default. Endpoints that legitimately return HTML (for example, to highlight the search term) can opt back in to the previous behavior by setting optionsashtml: true. The AutocompleteChoiceTypeExtension normalizer that previously forced…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-mwqm-4fw3-cjvr

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-49216

Advisory: symfony/ux-autocomplete: XSS via unescaped AJAX response data
IDs: CVE-2026-49216, GHSA-mwqm-4fw3-cjvr
Record: https://patchnext.com/advisories/cve-2026-49216 (revision 1, source checked 26 Oct 2026, 14:49 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: symfony/ux-autocomplete 3.1.0, 2.36.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist symfony/ux-autocomplete: affected >= 2.2.0, < 2.36.0; >= 3.0.0, < 3.1.0; fixed in 3.1.0, 2.36.0

## Suggested inspection (read-only)
- Packagist symfony/ux-autocomplete: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on symfony/ux-autocomplete.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-mwqm-4fw3-cjvr (GitHub-reviewed advisory GHSA-mwqm-4fw3-cjvr lists affected ranges: Packagist symfony/ux-autocomplete >=2.2.0 =3.0.0 <3.1.0)

Commands are suggestions: review each one before running it.

Loading voting…