Skip to content

← Actionable
Medium, CVSS 5.3

guzzlehttp/psr7 has CRLF Injection via URI Host Component

CVE-2026-49214GHSA-hq7v-mx3g-29hw

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (guzzlehttp/psr7 2.10.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
EPSS
  • CVE-2026-49214: 0.19% estimated exploitation activity in the next 30 days; percentile 8.69 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact guzzlehttp/psr7 did not reject ASCII control characters, whitespace, or DEL in first-party URI host components. The issue requires a PSR-7 request to be serialized into a raw HTTP/1.x message, for example with GuzzleHttp\Psr7\Message::toString() or an equivalent custom serializer. Creating a Uri, Request, or other PSR-7 object alone is not sufficient. The malformed host must be copied into the serialized Host header without further validation. A vulnerable flow is: 1. An application accepts a user-controlled URL. 2. The URL is used to construct a PSR-7 Uri or Request. 3. The host component contains CRLF or another header-unsafe character. 4. The request is serialized into a raw HTTP/1.x message without an explicit Host header. 5. The host is copied into the serialized Host header. 6. The serialized request is written to the network or otherwise processed by software that does not independently reject the malformed host. In that flow, an attacker can cause the serialized…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-hq7v-mx3g-29hw

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-49214

Advisory: guzzlehttp/psr7 has CRLF Injection via URI Host Component
IDs: CVE-2026-49214, GHSA-hq7v-mx3g-29hw
Record: https://patchnext.com/advisories/cve-2026-49214 (revision 1, source checked 26 Oct 2026, 14:50 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: guzzlehttp/psr7 2.10.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist guzzlehttp/psr7: affected < 2.10.2; fixed in 2.10.2

## Suggested inspection (read-only)
- Packagist guzzlehttp/psr7: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on guzzlehttp/psr7.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-hq7v-mx3g-29hw (GitHub-reviewed advisory GHSA-hq7v-mx3g-29hw lists affected ranges: Packagist guzzlehttp/psr7 >=0 <2.10.2)

Commands are suggestions: review each one before running it.

Loading voting…