Skip to content

← Actionable
High, CVSS 7.1amended

ONNX: TOCTOU arbitrary file read/write in save_external_dat

CVE-2026-49114GHSA-q56x-g2fj-4rj6

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (onnx 1.21.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI onnx

    Affected
    <= 1.20.1
    Fixed in
    1.21.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.1 · CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:H
EPSS
  • CVE-2026-49114: 0.16% estimated exploitation activity in the next 30 days; percentile 5.10 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The saveexternaldata method seems to include multiple issues introducing a local TOCTOU vulnerability, an arbitrary file read/write on any system. It potentially includes a path validation bypass on Windows systems. Regarding the TOCTOU, an attacker seems to be able to overwrite victim's files via symlink following under the same privilege scope. The mentioned function can be found here: https://github.com/onnx/onnx/blob/main/onnx/externaldatahelper.py#L188 Details Toctou The vulnerable code pattern: There is a time gap between os.path.isfile and open with no atomic file creation flags (e.g. OEXCEL | OCREAT) allowing the attacker to create a symlink that is being followed (absence of ONOFOLLOW), between these two calls. By combining these, the attack is possible as shown below in the PoC section. Bypass There is also a potential validation bypass on Windows systems in the same method (https://github.com/onnx/onnx/blob/main/onnx/externaldatahelper.py#L203) allowing absolute…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-q56x-g2fj-4rj6

  2. Revision 1 · created ·

    Published from osv record GHSA-q56x-g2fj-4rj6

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-49114

Advisory: ONNX: TOCTOU arbitrary file read/write in save_external_dat
IDs: CVE-2026-49114, GHSA-q56x-g2fj-4rj6
Record: https://patchnext.com/advisories/cve-2026-49114 (revision 2, source checked 26 Oct 2026, 13:51 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: onnx 1.21.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI onnx: affected <= 1.20.1; fixed in 1.21.0

## Suggested inspection (read-only)
- `python -m pip show onnx`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on onnx.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-q56x-g2fj-4rj6 (OSV record GHSA-q56x-g2fj-4rj6 lists affected ranges: PyPI onnx >=0 <1.21.0 (fixed))
- Verified: https://github.com/advisories/GHSA-q56x-g2fj-4rj6 (GitHub-reviewed advisory GHSA-q56x-g2fj-4rj6 lists affected ranges: PyPI onnx >=0 <=1.20.1)

Commands are suggestions: review each one before running it.

Loading voting…