Skip to content

← Actionable
Medium, CVSS 5.3

guzzlehttp/psr7 has Host Confusion via Authority Reinterpretation

CVE-2026-48998GHSA-34xg-wgjx-8xph

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (guzzlehttp/psr7 2.10.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
EPSS
  • CVE-2026-48998: 0.20% estimated exploitation activity in the next 30 days; percentile 9.66 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact guzzlehttp/psr7 improperly interpreted malformed Host header values when constructing request URIs from inbound request data. This issue concerns inbound request parsing and server request construction. It does not require serializing a PSR-7 request, and it is not part of the normal outbound request-sending path used by guzzlehttp/guzzle. A vulnerable flow is: 1. An attacker controls a raw HTTP request or server variable containing a Host value. 2. The Host value contains URI authority delimiters, such as trusted.example@evil.example. 3. guzzlehttp/psr7 uses that value to construct a URI. 4. The URI parser treats the portion before @ as userinfo and the portion after @ as the URI host. 5. The resulting PSR-7 request URI host differs from the original Host header value. For example, Host: trusted.example@evil.example can result in a PSR-7 URI whose host is evil.example, while the original Host header value remains trusted.example@evil.example. Applications are affected if they…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-34xg-wgjx-8xph

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-48998

Advisory: guzzlehttp/psr7 has Host Confusion via Authority Reinterpretation
IDs: CVE-2026-48998, GHSA-34xg-wgjx-8xph
Record: https://patchnext.com/advisories/cve-2026-48998 (revision 1, source checked 26 Oct 2026, 14:50 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: guzzlehttp/psr7 2.10.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist guzzlehttp/psr7: affected < 2.10.2; fixed in 2.10.2

## Suggested inspection (read-only)
- Packagist guzzlehttp/psr7: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on guzzlehttp/psr7.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-34xg-wgjx-8xph (GitHub-reviewed advisory GHSA-34xg-wgjx-8xph lists affected ranges: Packagist guzzlehttp/psr7 >=0 <2.10.2)

Commands are suggestions: review each one before running it.

Loading voting…