Skip to content

← Actionable
Medium, CVSS 5.3amended

joserfc: b64=false RFC7797 JWS payloads bypass JWSRegistry payload-size limits during deserialization

CVE-2026-48990GHSA-wphv-vfrh-23q5

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (joserfc 1.6.7), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI joserfc

    Affected
    >= 1.3.4, < 1.6.7
    Fixed in
    1.6.7

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
EPSS
  • CVE-2026-48990: 0.16% estimated exploitation activity in the next 30 days; percentile 5.50 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

RFC7797 b64=false JWS payloads bypass JWSRegistry payload-size limits during deserialization Summary Testing revealed that joserfc accepts oversized RFC7797 b64=false JWS payloads without applying JWSRegistry.maxpayloadlength. The normal JWS compact and flattened JSON paths reject payloads above the configured payload-size limit with ExceededSizeError. The RFC7797 unencoded payload paths do not make the same check. A valid b64=false compact or flattened JSON JWS can therefore deserialize successfully with a payload larger than JWSRegistry.maxpayloadlength. This creates a moderate availability/resource-exhaustion risk for applications that accept lower-trust JWS values and rely on joserfc to reject oversized token content during verification. Affected Product - Package: joserfc - Ecosystem: pip - Audited release: 1.6.5 - Audit tag: 1.6.5 - Audit commit: 881712980934fb601bed26fe3ae1ec0b7780e6f7 - Tested affected releases: 1.3.4, 1.3.5, 1.4.2, 1.6.2, 1.6.3, 1.6.4, 1.6.5 - Fixed release:…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-wphv-vfrh-23q5

  2. Revision 1 · created ·

    Published from osv record GHSA-wphv-vfrh-23q5

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-48990

Advisory: joserfc: b64=false RFC7797 JWS payloads bypass JWSRegistry payload-size limits during deserialization
IDs: CVE-2026-48990, GHSA-wphv-vfrh-23q5
Record: https://patchnext.com/advisories/cve-2026-48990 (revision 2, source checked 26 Oct 2026, 13:46 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: joserfc 1.6.7. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI joserfc: affected >= 1.3.4, < 1.6.7; fixed in 1.6.7

## Suggested inspection (read-only)
- `python -m pip show joserfc`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on joserfc.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-wphv-vfrh-23q5 (OSV record GHSA-wphv-vfrh-23q5 lists affected ranges: PyPI joserfc >=1.3.4 <1.6.7 (fixed))
- Verified: https://github.com/advisories/GHSA-wphv-vfrh-23q5 (GitHub-reviewed advisory GHSA-wphv-vfrh-23q5 lists affected ranges: PyPI joserfc >=1.3.4 <1.6.7)

Commands are suggestions: review each one before running it.

Loading voting…