Jenkins AppSpider Plugin does not perform a permission check in a method implementing form validation
CVE-2026-48923GHSA-9wm7-8qf3-9v98
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (com.rapid7:jenkinsci-appspider-plugin 1.0.18), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven com.rapid7:jenkinsci-appspider-plugin
- Affected
- <= 1.0.17
- Fixed in
- 1.0.18
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-9wm7-8qf3-9v98 lists affected ranges: Maven com.rapid7:jenkinsci-appspider-plugin >=0 <=1.0.17
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
- EPSS
- CVE-2026-48923: 0.18% estimated exploitation activity in the next 30 days; percentile 7.66 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Jenkins AppSpider Plugin 1.0.17 and earlier does not perform a permission check in a method implementing form validation. This allows attackers with Overall/Read permission to connect to an attacker-specified URL. AppSpider Plugin 1.0.18 requires Overall/Administer permission to use the affected method implementing form validation.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-9wm7-8qf3-9v98
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-48923 Advisory: Jenkins AppSpider Plugin does not perform a permission check in a method implementing form validation IDs: CVE-2026-48923, GHSA-9wm7-8qf3-9v98 Record: https://patchnext.com/advisories/cve-2026-48923 (revision 1, source checked 26 Oct 2026, 16:54 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: com.rapid7:jenkinsci-appspider-plugin 1.0.18. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven com.rapid7:jenkinsci-appspider-plugin: affected <= 1.0.17; fixed in 1.0.18 ## Suggested inspection (read-only) - Maven com.rapid7:jenkinsci-appspider-plugin: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on com.rapid7:jenkinsci-appspider-plugin. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-9wm7-8qf3-9v98 (GitHub-reviewed advisory GHSA-9wm7-8qf3-9v98 lists affected ranges: Maven com.rapid7:jenkinsci-appspider-plugin >=0 <=1.0.17) Commands are suggestions: review each one before running it.
Loading voting…