Skip to content

← Actionable
Medium, CVSS 6.6

Jenkins Active Directory Plugin follows LDAP referrals by default

CVE-2026-48918GHSA-wrhr-54p6-q97f

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.jenkins-ci.plugins:active-directory 2.41.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.6 · CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-48918: 0.22% estimated exploitation activity in the next 30 days; percentile 12.96 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Jenkins Active Directory Plugin 2.41 and earlier follows LDAP referrals from the configured Active Directory server by default. These can forward to an RMI URL that causes Jenkins to deserialize attacker-controlled data, resulting in Remote Code Execution (RCE) on the Jenkins controller if deserialization "gadgets" are available on the classpath. This allows attackers able to control the configured Active Directory server, or able to perform a machine-in-the-middle attack, to execute code on the Jenkins controller. Active Directory Plugin 2.41.1 no longer follows LDAP referrals by default. Administrators unable to update to a fixed version can start Jenkins with the Java system property hudson.plugins.activedirectory.referral.ignore set to true to mitigate the vulnerability. Administrators of Jenkins controllers requiring following LDAP referrals can set the Java system property hudson.plugins.activedirectory.referral.ignore to false to restore the previous behavior.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-wrhr-54p6-q97f

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-48918

Advisory: Jenkins Active Directory Plugin follows LDAP referrals by default
IDs: CVE-2026-48918, GHSA-wrhr-54p6-q97f
Record: https://patchnext.com/advisories/cve-2026-48918 (revision 1, source checked 26 Oct 2026, 16:54 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.jenkins-ci.plugins:active-directory 2.41.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.jenkins-ci.plugins:active-directory: affected < 2.41.1; fixed in 2.41.1

## Suggested inspection (read-only)
- Maven org.jenkins-ci.plugins:active-directory: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.jenkins-ci.plugins:active-directory.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-wrhr-54p6-q97f (GitHub-reviewed advisory GHSA-wrhr-54p6-q97f lists affected ranges: Maven org.jenkins-ci.plugins:active-directory >=0 <2.41.1)

Commands are suggestions: review each one before running it.

Loading voting…