Skip to content

← Actionable
Medium, CVSS 4.3amended

Apache Airflow exposes unreadable DAG identifiers in the scheduling dependencies graph

CVE-2026-48891GHSA-3322-mjxh-9mp5

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (apache-airflow 3.3.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
EPSS
  • CVE-2026-48891: 0.64% estimated exploitation activity in the next 30 days; percentile 50.55 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A bug in Apache Airflow's /ui/dependencies scheduling graph endpoint applied the caller's readable-Dag filter to the top-level serialized Dag key but still emitted referenced Dag IDs through the dep.source and dep.target fields of trigger / sensor dependency entries. An authenticated UI user with read permission on some Dags could enumerate the identifiers of other Dags they were not authorized to read by inspecting the dependency graph for trigger / sensor references. Affects deployments that rely on per-Dag read scoping to keep Dag identifiers private across teams. This is a residual gap in the fix for CVE-2026-28563, which filtered the top-level Dag key but did not propagate the filter into the trigger / sensor dep-source / dep-target fields. Users who already upgraded for CVE-2026-28563 should additionally upgrade to apache-airflow 3.3.0 or later to cover the residual trigger / sensor dependency leak.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-3322-mjxh-9mp5

  2. Revision 1 · created ·

    Published from osv record GHSA-3322-mjxh-9mp5

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-48891

Advisory: Apache Airflow exposes unreadable DAG identifiers in the scheduling dependencies graph
IDs: CVE-2026-48891, GHSA-3322-mjxh-9mp5
Record: https://patchnext.com/advisories/cve-2026-48891 (revision 2, source checked 26 Oct 2026, 13:51 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: apache-airflow 3.3.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI apache-airflow: affected < 3.3.0; fixed in 3.3.0

## Suggested inspection (read-only)
- `python -m pip show apache-airflow`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on apache-airflow.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-3322-mjxh-9mp5 (OSV record GHSA-3322-mjxh-9mp5 lists affected ranges: PyPI apache-airflow >=0 <3.3.0 (fixed))
- Verified: https://github.com/advisories/GHSA-3322-mjxh-9mp5 (GitHub-reviewed advisory GHSA-3322-mjxh-9mp5 lists affected ranges: PyPI apache-airflow >=0 <3.3.0)

Commands are suggestions: review each one before running it.

Loading voting…