Apache Airflow exposes sensitive JSON Variable values through the Bulk Variables API
CVE-2026-48828GHSA-563f-2439-rmq4
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (apache-airflow 3.3.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI apache-airflow
- Affected
- < 3.3.0
- Fixed in
- 3.3.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-563f-2439-rmq4 lists affected ranges: PyPI apache-airflow >=0 <3.3.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-563f-2439-rmq4 lists affected ranges: PyPI apache-airflow >=0 <3.3.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2026-48828: 0.66% estimated exploitation activity in the next 30 days; percentile 51.79 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The Bulk Variables API in Apache Airflow called the redactor without passing the variable's key, so the key-based shouldhidevalueforkey check (which triggers on secret-suffixed key names like password / token / secret) could not fire for JSON-decodable variable values. An authenticated UI/API user with bulk Variable read permission could retrieve plaintext values from JSON variables whose key would otherwise trigger redaction. Affects deployments that store sensitive values in JSON-typed Airflow Variables under secret-suffixed key names. Users are advised to upgrade to apache-airflow 3.3.0 or later (the fix landed on main after 3.2.2; no 3.2.x backport).
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-563f-2439-rmq4
- Revision 1 · created ·
Published from osv record GHSA-563f-2439-rmq4
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-48828 Advisory: Apache Airflow exposes sensitive JSON Variable values through the Bulk Variables API IDs: CVE-2026-48828, GHSA-563f-2439-rmq4 Record: https://patchnext.com/advisories/cve-2026-48828 (revision 2, source checked 26 Oct 2026, 13:51 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: apache-airflow 3.3.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI apache-airflow: affected < 3.3.0; fixed in 3.3.0 ## Suggested inspection (read-only) - `python -m pip show apache-airflow`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on apache-airflow. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-563f-2439-rmq4 (OSV record GHSA-563f-2439-rmq4 lists affected ranges: PyPI apache-airflow >=0 <3.3.0 (fixed)) - Verified: https://github.com/advisories/GHSA-563f-2439-rmq4 (GitHub-reviewed advisory GHSA-563f-2439-rmq4 lists affected ranges: PyPI apache-airflow >=0 <3.3.0) Commands are suggestions: review each one before running it.
Loading voting…