Apache MINA SSHD bundle sshd-git has a path traversal vulnerability
CVE-2026-48827GHSA-mw4m-qhpg-j82m
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.sshd:sshd-git 3.0.0-M4, 2.18.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.sshd:sshd-git
- Affected
- < 2.18.0>= 3.0.0-M1, < 3.0.0-M4
- Fixed in
- 3.0.0-M4, 2.18.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-mw4m-qhpg-j82m lists affected ranges: Maven org.apache.sshd:sshd-git >=0 =3.0.0-M1 <3.0.0-M4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.1 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:N
- EPSS
- CVE-2026-48827: 0.53% estimated exploitation activity in the next 30 days; percentile 44.71 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
There is a path traversal vulnerability in Apache MINA SSHD bundle sshd-git. Lack of path validation in git-upload-pack, git-receive-pack, and other git operations allows users authenticated over SSH access to git repositories outside the configured git server root directory. Applications are affected if they use org.apache.sshd:sshd-git. Applications not using sshd-git are not affected. Users are advised to upgrade affected applications to Apche MINA SSHD 2.18.0, which fixes the issue. The issue also is present in the pre-release milestones 3.0.0-M1 to 3.0.0-M3 for a new upcoming new major version 3.0.0. Again, applications are affected only if they use sshd-git. Upgrade affected applications to 3.0.0-M4. Apache MINA SSHD bundle sshd-git would like to point out that a professional git server should not rely solely on file system layout and permissions, but should implement additional security controls to govern access to git repositories and operations allowed on particular git…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-mw4m-qhpg-j82m
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-48827 Advisory: Apache MINA SSHD bundle sshd-git has a path traversal vulnerability IDs: CVE-2026-48827, GHSA-mw4m-qhpg-j82m Record: https://patchnext.com/advisories/cve-2026-48827 (revision 1, source checked 26 Oct 2026, 16:54 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.apache.sshd:sshd-git 3.0.0-M4, 2.18.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.sshd:sshd-git: affected < 2.18.0; >= 3.0.0-M1, < 3.0.0-M4; fixed in 3.0.0-M4, 2.18.0 ## Suggested inspection (read-only) - Maven org.apache.sshd:sshd-git: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.sshd:sshd-git. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-mw4m-qhpg-j82m (GitHub-reviewed advisory GHSA-mw4m-qhpg-j82m lists affected ranges: Maven org.apache.sshd:sshd-git >=0 =3.0.0-M1 <3.0.0-M4) Commands are suggestions: review each one before running it.
Loading voting…