Skip to content

← Actionable
Medium, CVSS 4.8amended

@hey-api/openapi-ts's buildClientParams template: prototype chain substitution via unknown $ ___proto__ key

CVE-2026-48819GHSA-hhx9-57xq-r5rw

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@hey-api/openapi-ts 0.97.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.8 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N
EPSS
  • CVE-2026-48819: 0.27% estimated exploitation activity in the next 30 days; percentile 19.59 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary dist/clients/core/params.ts in @hey-api/openapi-ts ships a runtime template that is copied verbatim into every generated SDK as params.gen.ts. When a caller passes an object argument containing an unknown key starting with a slot prefix ($body, $headers, $path, $query), the function strips the prefix and writes the remainder directly to that slot without validation. The key "$queryproto" causes the returned params.query object to have its prototype chain substituted with attacker-controlled data. The issue is present in all versions through at least 0.97.2. Details The vulnerable branch in dist/clients/core/params.ts: This branch runs for any key that (1) is not registered in the field map and (2) starts with one of the four slot prefixes. When a caller passes "$queryproto" as an extra key alongside a legitimate field, the key is not in the field map, key.startsWith("$query") is true, and key.slice(7) produces "proto". The bracket-write params["query"]["proto"] = value…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-hhx9-57xq-r5rw

  2. Revision 1 · created ·

    Published from osv record GHSA-hhx9-57xq-r5rw

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-48819

Advisory: @hey-api/openapi-ts's `buildClientParams` template: prototype chain substitution via unknown `$ ___proto__` key
IDs: CVE-2026-48819, GHSA-hhx9-57xq-r5rw
Record: https://patchnext.com/advisories/cve-2026-48819 (revision 2, source checked 26 Oct 2026, 13:01 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @hey-api/openapi-ts 0.97.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @hey-api/openapi-ts: affected < 0.97.3; fixed in 0.97.3

## Suggested inspection (read-only)
- `npm ls @hey-api/openapi-ts --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @hey-api/openapi-ts.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-hhx9-57xq-r5rw (OSV record GHSA-hhx9-57xq-r5rw lists affected ranges: npm @hey-api/openapi-ts >=0 <0.97.3 (fixed))
- Verified: https://github.com/advisories/GHSA-hhx9-57xq-r5rw (GitHub-reviewed advisory GHSA-hhx9-57xq-r5rw lists affected ranges: npm @hey-api/openapi-ts >=0 <0.97.3)

Commands are suggestions: review each one before running it.

Loading voting…