Skip to content

← Actionable
High, CVSS 7.5amended

sigstore's certificateOIDs verification constraints are silently dropped and never enforced

CVE-2026-48815GHSA-52v5-jr5w-gjxr

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (sigstore 4.1.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm sigstore

    Affected
    <= 4.1.0
    Fixed in
    4.1.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
EPSS
  • CVE-2026-48815: 0.17% estimated exploitation activity in the next 30 days; percentile 6.82 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The documented certificateOIDs option in sigstore.verify() is accepted by the public API but discarded before verification, so required certificate extension OIDs are never checked. Details The public verify options include certificateOIDs and the documentation says those OID/value pairs “must be present in the certificate’s extension list.” The policy-construction path used by sigstore.verify() and createVerifier() only copies the SAN and issuer settings into the verification policy and completely ignores certificateOIDs. As a result, callers can believe they are constraining verification to certificates carrying specific Fulcio or workload-identifying OIDs, while the actual verifier never receives those constraints. Any bundle that satisfies the remaining checks is accepted even if the required OID extensions are absent or mismatched. This is reachable from supported usage through the documented certificateOIDs verify option. PoC Impact Applications that rely on…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-52v5-jr5w-gjxr

  2. Revision 1 · created ·

    Published from osv record GHSA-52v5-jr5w-gjxr

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-48815

Advisory: sigstore's `certificateOIDs` verification constraints are silently dropped and never enforced
IDs: CVE-2026-48815, GHSA-52v5-jr5w-gjxr
Record: https://patchnext.com/advisories/cve-2026-48815 (revision 2, source checked 26 Oct 2026, 12:56 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: sigstore 4.1.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm sigstore: affected <= 4.1.0; fixed in 4.1.1

## Suggested inspection (read-only)
- `npm ls sigstore --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on sigstore.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-52v5-jr5w-gjxr (OSV record GHSA-52v5-jr5w-gjxr lists affected ranges: npm sigstore >=0 <4.1.1 (fixed))
- Verified: https://github.com/advisories/GHSA-52v5-jr5w-gjxr (GitHub-reviewed advisory GHSA-52v5-jr5w-gjxr lists affected ranges: npm sigstore >=0 <=4.1.0)

Commands are suggestions: review each one before running it.

Loading voting…