Skip to content

← Actionable
Critical, CVSS 9.1amended

Network-AI: CVE-2026-46701 fix incomplete — empty default secret still authorizes all requests

CVE-2026-48814GHSA-r78r-rwrf-rjwp

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (network-ai 5.7.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
EPSS
  • CVE-2026-48814: 0.45% estimated exploitation activity in the next 30 days; percentile 38.75 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Advisory / Disclosure Network-AI — CVE-2026-46701 fix is incomplete: the "Empty Default Secret" unauth path survives Target: Jovancoding/Network-AI (npm network-ai), latest v5.7.1 Status: the advisory ("Unauthenticated Cross-Origin MCP Tool Invocation via Empty Default Secret") named three flaws. The fix (5.4.5) closed the CORS flaw (Access-Control-Allow-Origin is now set only for localhost origins), but left the empty-default-secret flaw the title is about: the SSE MCP server still defaults to an empty secret, isAuthorized() still returns true when the secret is empty, and a non-loopback bind only warns. So the server still runs fully unauthenticated by default — any non-browser caller (curl, SSRF, or a 0.0.0.0 bind) can invoke all 22 MCP tools (configset, agentspawn, blackboardwrite, token) with no credentials. Class: CWE-306/CWE-862 Missing Authentication — incomplete fix. Methodology: M1 incomplete-fix audit (anchor = the 5.4.5 fix; sibling-walk on latest v5.7.1, executed).…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-r78r-rwrf-rjwp

  2. Revision 2 · amended ·

    Amended from osv record GHSA-r78r-rwrf-rjwp

  3. Revision 1 · created ·

    Published from ghsa record GHSA-r78r-rwrf-rjwp

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-48814

Advisory: Network-AI: CVE-2026-46701 fix incomplete — empty default secret still authorizes all requests
IDs: CVE-2026-48814, GHSA-r78r-rwrf-rjwp
Record: https://patchnext.com/advisories/cve-2026-48814 (revision 3, source checked 26 Oct 2026, 12:56 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: network-ai 5.7.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm network-ai: affected <= 5.7.1; fixed in 5.7.2

## Suggested inspection (read-only)
- `npm ls network-ai --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on network-ai.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-r78r-rwrf-rjwp (GitHub-reviewed advisory GHSA-r78r-rwrf-rjwp lists affected ranges: npm network-ai >=0 <=5.7.1)
- Verified: https://osv.dev/vulnerability/GHSA-r78r-rwrf-rjwp (OSV record GHSA-r78r-rwrf-rjwp lists affected ranges: npm network-ai >=0 <5.7.2 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…