Skip to content

← Actionable
High, CVSS 7.5amended

python-engineio has possible denial of service due to maximum payload size sometimes not being enforced

CVE-2026-48809GHSA-m9gh-vj53-gvh9

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (python-engineio 4.13.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2026-48809: 0.49% estimated exploitation activity in the next 30 days; percentile 42.05 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact There are two specific configurations of the python-engineio server in which the size of incoming messages is not checked before the messages are loaded into memory. An attacker can take advantage of these to cause unnecessary memory allocations in the python-engineio server. The two cases are: - POST requests, when using ASGI with the long polling transport - WebSocket messages, when using Aiohttp with the WebSocket transport Patches Version 4.13.2 addresses this issue as follows: - ASGI severs now only load the body of incoming requests into memory after the client is confirmed to be known and authenticated, and the payload size is below the maximum allowed size. Requests that do not comply with these requirements are discarded. - Aiohttp servers configure the maximum payload size in the underlying WebSocket layer from Aiohttp, so that large messages are discarded by Aiohttp before they are delivered to python-engineio.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-m9gh-vj53-gvh9

  2. Revision 1 · created ·

    Published from osv record GHSA-m9gh-vj53-gvh9

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-48809

Advisory: python-engineio has possible denial of service due to maximum payload size sometimes not being enforced
IDs: CVE-2026-48809, GHSA-m9gh-vj53-gvh9
Record: https://patchnext.com/advisories/cve-2026-48809 (revision 2, source checked 26 Oct 2026, 13:46 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: python-engineio 4.13.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI python-engineio: affected <= 4.13.1; fixed in 4.13.2

## Suggested inspection (read-only)
- `python -m pip show python-engineio`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on python-engineio.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-m9gh-vj53-gvh9 (OSV record GHSA-m9gh-vj53-gvh9 lists affected ranges: PyPI python-engineio >=0 <4.13.2 (fixed))
- Verified: https://github.com/advisories/GHSA-m9gh-vj53-gvh9 (GitHub-reviewed advisory GHSA-m9gh-vj53-gvh9 lists affected ranges: PyPI python-engineio >=0 <=4.13.1)

Commands are suggestions: review each one before running it.

Loading voting…