Skip to content

← Actionable
Unrated

Twig: Sandbox __toString() policy bypass via Traversable in join and replace filters

CVE-2026-48807GHSA-8x9c-rmqh-456c

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (twig/twig 3.27.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist twig/twig

    Affected
    <= 3.26.0
    Fixed in
    3.27.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
  • CVE-2026-48807: 0.37% estimated exploitation activity in the next 30 days; percentile 30.61 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Description This is a residual bypass of CVE-2026-47732 / GHSA-pr2w-4gpj-cpq4 left after the initial fix for unguarded toString() calls. It covers two related coercion points that were not caught by the original patch. Traversable in join and replace filters. SandboxExtension::ensureToStringAllowed() recurses into PHP arrays so that a Stringable object hidden inside an array argument cannot be string-coerced without consulting the security policy. The recursion stops at PHP arrays: a Traversable value passed at the same position is not materialised, so its contents are not policy-checked. CoreExtension::join() and CoreExtension::replace() later materialise such Traversable inputs through self::toArray() and feed them to implode() / strtr(), both of which implicitly call toString() on contained Stringable objects. The bypass also reproduces when the container implements both Stringable and Traversable: the container's own toString() is policy-checked, but the elements yielded by…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-8x9c-rmqh-456c

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-48807

Advisory: Twig: Sandbox `__toString()` policy bypass via `Traversable` in `join` and `replace` filters
IDs: CVE-2026-48807, GHSA-8x9c-rmqh-456c
Record: https://patchnext.com/advisories/cve-2026-48807 (revision 1, source checked 26 Oct 2026, 14:49 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: twig/twig 3.27.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist twig/twig: affected <= 3.26.0; fixed in 3.27.0

## Suggested inspection (read-only)
- Packagist twig/twig: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on twig/twig.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-8x9c-rmqh-456c (GitHub-reviewed advisory GHSA-8x9c-rmqh-456c lists affected ranges: Packagist twig/twig >=0 <=3.26.0)

Commands are suggestions: review each one before running it.

Loading voting…