Backpropagate: backprop ui --auth and backprop ui --share do not enforce authentication
CVE-2026-48797GHSA-f65r-h4g3-3h9h
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@mcptoolshop/backpropagate 1.2.0; backpropagate 1.2.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @mcptoolshop/backpropagate
- Affected
- >= 1.1.0, < 1.2.0
- Fixed in
- 1.2.0
PyPI backpropagate
- Affected
- >= 1.1.0, < 1.2.0
- Fixed in
- 1.2.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-f65r-h4g3-3h9h lists affected ranges: PyPI backpropagate >=1.1.0 =1.1.0 <1.2.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-f65r-h4g3-3h9h lists affected ranges: PyPI backpropagate >=1.1.0 =1.1.0 <1.2.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 9.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-48797: 0.32% estimated exploitation activity in the next 30 days; percentile 25.55 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary In `backpropagate >= 1.1.0`, the optional Reflex web UI (`pip install backpropagate[ui]`, launched via `backprop ui`) exposes a training control plane: dataset upload, model load, training start/stop, multi-run orchestration, GGUF export, and HuggingFace Hub push. The CLI accepts two operator-facing flags intended as security controls: - `--auth user:pass` — documented as "require HTTP Basic authentication on every request to the UI." - `--share` — documented as "expose the UI on a public address; requires `--auth`." When `--auth user:pass` is passed, the CLI prints `Auth: enabled (user: )` to confirm to the operator that authentication is active, then exports `BACKPROPAGATE_UI_AUTH=user:pass` to the subprocess that launches the Reflex backend. The Reflex backend (`backpropagate/ui_app/`) never reads `BACKPROPAGATE_UI_AUTH`.** No authentication middleware is registered. No request-level guard runs. No WebSocket upgrade guard runs. Any client that reaches the bound port…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 6 · amended ·
Amended from osv record GHSA-f65r-h4g3-3h9h
- Revision 5 · amended ·
Amended from ghsa record GHSA-f65r-h4g3-3h9h
- Revision 4 · amended ·
Amended from ghsa record GHSA-f65r-h4g3-3h9h
- Revision 3 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 2 · amended ·
Amended from osv record GHSA-f65r-h4g3-3h9h
- Revision 1 · created ·
Published from ghsa record GHSA-f65r-h4g3-3h9h
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-48797 Advisory: Backpropagate: backprop ui --auth and backprop ui --share do not enforce authentication IDs: CVE-2026-48797, GHSA-f65r-h4g3-3h9h Record: https://patchnext.com/advisories/cve-2026-48797 (revision 6, source checked 28 Oct 2026, 06:00 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @mcptoolshop/backpropagate 1.2.0; backpropagate 1.2.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @mcptoolshop/backpropagate: affected >= 1.1.0, < 1.2.0; fixed in 1.2.0 - PyPI backpropagate: affected >= 1.1.0, < 1.2.0; fixed in 1.2.0 ## Suggested inspection (read-only) - `npm ls @mcptoolshop/backpropagate --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `python -m pip show backpropagate`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @mcptoolshop/backpropagate, backpropagate. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-f65r-h4g3-3h9h (GitHub-reviewed advisory GHSA-f65r-h4g3-3h9h lists affected ranges: PyPI backpropagate >=1.1.0 =1.1.0 <1.2.0) - Verified: https://osv.dev/vulnerability/GHSA-f65r-h4g3-3h9h (OSV record GHSA-f65r-h4g3-3h9h lists affected ranges: PyPI backpropagate >=1.1.0 =1.1.0 <1.2.0 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…