Skip to content

← Actionable
Medium, CVSS 4.8

Apptainer has incorrect path matching for 'limit container paths' directive

CVE-2026-48785GHSA-cr2j-534f-mf3g

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/apptainer/apptainer 1.5.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.8 · CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:L
EPSS
  • CVE-2026-48785: 0.15% estimated exploitation activity in the next 30 days; percentile 4.20 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The limit container paths directive in apptainer.conf is intended to allow a system administrator limit the paths from which containers can be run, under setuid mode. Due to incorrect matching of a path string, sibling directories with similar names may incorrectly be allowed. For example, the configuration: Will also allow containers in /data/safe-but-unsafe to be run. Patches The issue is patched in apptainer version 1.5.1. Workarounds If developers do not use setuid mode or do not use the limit container paths functionality, then this issue does not affect their installation. Note that, as documented [1], if user namespaces are allowed for unrestricted use then this functionality does not stop users from running any container of their choice. If developers do use the limit container paths functionality they are advised to update. Credit This vulnerability was discovered and disclosed to the Apptainer project by Dave Trudgian of Sylabs. Resources [1]…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-cr2j-534f-mf3g

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-48785

Advisory: Apptainer has incorrect path matching for 'limit container paths' directive
IDs: CVE-2026-48785, GHSA-cr2j-534f-mf3g
Record: https://patchnext.com/advisories/cve-2026-48785 (revision 1, source checked 26 Oct 2026, 15:24 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/apptainer/apptainer 1.5.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/apptainer/apptainer: affected < 1.5.1; fixed in 1.5.1

## Suggested inspection (read-only)
- Go github.com/apptainer/apptainer: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/apptainer/apptainer.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-cr2j-534f-mf3g (GitHub-reviewed advisory GHSA-cr2j-534f-mf3g lists affected ranges: Go github.com/apptainer/apptainer >=0 <1.5.1)

Commands are suggestions: review each one before running it.

Loading voting…