pydantic-ai: SSRF blocklist bypass via IPv4-compatible, SIIT/IVI, and local NAT64 IPv6 addresses (incomplete fix of CVE-2026-46678)
CVE-2026-48782GHSA-cg7w-rg45-pc59
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (pydantic-ai 2.0.0b3, 1.102.0; pydantic-ai-slim 2.0.0b3, 1.102.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI pydantic-ai
- Affected
- >= 1.56.0, < 1.102.0>= 2.0.0b1, < 2.0.0b3
- Fixed in
- 2.0.0b3, 1.102.0
PyPI pydantic-ai-slim
- Affected
- >= 1.56.0, < 1.102.0>= 2.0.0b1, < 2.0.0b3
- Fixed in
- 2.0.0b3, 1.102.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-cg7w-rg45-pc59 lists affected ranges: PyPI pydantic-ai-slim >=1.56.0 =2.0.0b1 =1.56.0 =2.0.0b1 <2.0.0b3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-cg7w-rg45-pc59 lists affected ranges: PyPI pydantic-ai-slim >=1.56.0 =2.0.0b1 =1.56.0 =2.0.0b1 <2.0.0b3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.8 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:N/A:N
- EPSS
- CVE-2026-48782: 0.40% estimated exploitation activity in the next 30 days; percentile 34.37 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary When an application using Pydantic AI opts a URL into forcedownload='allow-local' (which disables the default block on private/internal IPs) and runs on a network that routes the affected IPv6 transition forms (NAT64- or ISATAP-configured networks), the cloud-metadata blocklist could be bypassed by encoding the metadata IP in an IPv6 transition form that the previous fix did not decode — IPv4-compatible IPv6 (::a.b.c.d), the NAT64 RFC 8215 local-use prefix (64:ff9b:1::/48), operator-chosen NAT64 prefixes, or ISATAP. The IPv6 wrapper is then delivered to the underlying IPv4 metadata endpoint, exposing cloud IAM short-term credentials. The bypass is exploitable only in environments whose network actually routes these forms — NAT64-configured networks (IPv6-only or dual-stack-with-NAT64 deployments, including some Kubernetes setups) for the NAT64 variants, or networks with an ISATAP tunnel for ISATAP. A standard dual-stack cloud VM or container does not route them and is not…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-cg7w-rg45-pc59
- Revision 1 · created ·
Published from osv record GHSA-cg7w-rg45-pc59
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-48782 Advisory: pydantic-ai: SSRF blocklist bypass via IPv4-compatible, SIIT/IVI, and local NAT64 IPv6 addresses (incomplete fix of CVE-2026-46678) IDs: CVE-2026-48782, GHSA-cg7w-rg45-pc59 Record: https://patchnext.com/advisories/cve-2026-48782 (revision 2, source checked 26 Oct 2026, 13:46 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: pydantic-ai 2.0.0b3, 1.102.0; pydantic-ai-slim 2.0.0b3, 1.102.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI pydantic-ai: affected >= 1.56.0, < 1.102.0; >= 2.0.0b1, < 2.0.0b3; fixed in 2.0.0b3, 1.102.0 - PyPI pydantic-ai-slim: affected >= 1.56.0, < 1.102.0; >= 2.0.0b1, < 2.0.0b3; fixed in 2.0.0b3, 1.102.0 ## Suggested inspection (read-only) - `python -m pip show pydantic-ai`: prints the installed version. Run with the environment that serves production active. - `python -m pip show pydantic-ai-slim`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on pydantic-ai, pydantic-ai-slim. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-cg7w-rg45-pc59 (OSV record GHSA-cg7w-rg45-pc59 lists affected ranges: PyPI pydantic-ai-slim >=1.56.0 =2.0.0b1 =1.56.0 =2.0.0b1 <2.0.0b3 (fixed)) - Verified: https://github.com/advisories/GHSA-cg7w-rg45-pc59 (GitHub-reviewed advisory GHSA-cg7w-rg45-pc59 lists affected ranges: PyPI pydantic-ai-slim >=1.56.0 =2.0.0b1 =1.56.0 =2.0.0b1 <2.0.0b3) Commands are suggestions: review each one before running it.
Loading voting…