ws: Memory exhaustion DoS from tiny fragments and data chunks
CVE-2026-48779GHSA-96hv-2xvq-fx4p
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (ws 8.21.0, 7.5.11, 6.2.4, 5.2.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm ws
- Affected
- >= 1.1.0, < 5.2.5>= 6.0.0, < 6.2.4>= 7.0.0, < 7.5.11>= 8.0.0, < 8.21.0
- Fixed in
- 5.2.5, 6.2.4, 7.5.11, 8.21.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-96hv-2xvq-fx4p lists affected ranges: npm ws >=1.1.0 =6.0.0 =7.0.0 =8.0.0 <8.21.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-96hv-2xvq-fx4p lists affected ranges: npm ws >=1.1.0 =6.0.0 =7.0.0 =8.0.0 <8.21.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2026-48779: 1.43% estimated exploitation activity in the next 30 days; percentile 72.97 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact A high volume of exceptionally small fragments and data chunks can be sent by a peer, with modest network traffic, to force the remote peer into allocating and holding structural wrappers that consume far more memory than the default documented message-size limit, leading to process termination due to OOM. Proof of concept Patches The vulnerability was fixed in ws@8.21.0 (https://github.com/websockets/ws/commit/bca91adf15677e47dbe4f959653452727be28b94) and backported to ws@7.5.11 (https://github.com/websockets/ws/commit/fd36cd864fcdf62a08273a99e19a7d975401fee8), ws@6.2.4 (https://github.com/websockets/ws/commit/86d3e8a5fb0246ed373860c5fbb0de88824a27f7), and ws@5.2.5 (https://github.com/websockets/ws/commit/b5372ac67bb97a773727b8e9f5035a8123556d53). Workarounds In vulnerable versions, the issue can be mitigated by lowering the value of the maxPayload option if possible. Credits The vulnerability was responsibly disclosed and fixed by Nadav Magier.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-96hv-2xvq-fx4p
- Revision 1 · created ·
Published from osv record GHSA-96hv-2xvq-fx4p
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-48779 Advisory: ws: Memory exhaustion DoS from tiny fragments and data chunks IDs: CVE-2026-48779, GHSA-96hv-2xvq-fx4p Record: https://patchnext.com/advisories/cve-2026-48779 (revision 2, source checked 26 Oct 2026, 12:56 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: ws 8.21.0, 7.5.11, 6.2.4, 5.2.5. A vendor fix does not mean a deployment is fixed. ## Affected components - npm ws: affected >= 1.1.0, < 5.2.5; >= 6.0.0, < 6.2.4; >= 7.0.0, < 7.5.11; >= 8.0.0, < 8.21.0; fixed in 5.2.5, 6.2.4, 7.5.11, 8.21.0 ## Suggested inspection (read-only) - `npm ls ws --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on ws. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-96hv-2xvq-fx4p (OSV record GHSA-96hv-2xvq-fx4p lists affected ranges: npm ws >=1.1.0 =6.0.0 =7.0.0 =8.0.0 <8.21.0 (fixed)) - Verified: https://github.com/advisories/GHSA-96hv-2xvq-fx4p (GitHub-reviewed advisory GHSA-96hv-2xvq-fx4p lists affected ranges: npm ws >=1.1.0 =6.0.0 =7.0.0 =8.0.0 <8.21.0) Commands are suggestions: review each one before running it.
Loading voting…