LangGraph SDK has unsafe URL path construction
CVE-2026-48776GHSA-w39p-vh2g-g8g5
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (langgraph 0.3.15; langgraph-sdk 0.3.15), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI langgraph
- Affected
- < 0.3.15
- Fixed in
- 0.3.15
PyPI langgraph-sdk
- Affected
- < 0.3.15
- Fixed in
- 0.3.15
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-w39p-vh2g-g8g5 lists affected ranges: PyPI langgraph-sdk >=0 <0.3.15 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record PYSEC-2026-2194 lists affected ranges: PyPI langgraph >=0 <0.3.15 (fixed)
VerifiedObserved Structured OSV record; not marked as GitHub-reviewed.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-w39p-vh2g-g8g5 lists affected ranges: PyPI langgraph-sdk >=0 <0.3.15
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.2 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:N
- EPSS
- CVE-2026-48776: 0.22% estimated exploitation activity in the next 30 days; percentile 12.17 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary langgraph-sdk constructs HTTP request paths for resource operations by interpolating caller-supplied identifier values into URL templates. Without sanitization of those values, identifiers that contain characters with special meaning in URL paths could cause the resulting request to address a different resource (and potentially a different resource type) than the SDK method's call site indicates. In deployments where the SDK receives identifier values that originate from untrusted sources, this could result in unintended access, modification, or deletion of resources beyond the calling user's authorization scope. This issue is most consequential in deployments that: - forward end-user-supplied values directly into SDK identifier parameters without first validating them against an expected format (such as a UUID), and - rely on URL-prefix-based authorization at an upstream layer (reverse proxy, edge gateway, WAF), where the authorization decision is made on the SDK call's…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-w39p-vh2g-g8g5
- Revision 2 · amended ·
Amended from osv record PYSEC-2026-2194
- Revision 1 · created ·
Published from osv record GHSA-w39p-vh2g-g8g5
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-48776 Advisory: LangGraph SDK has unsafe URL path construction IDs: CVE-2026-48776, GHSA-w39p-vh2g-g8g5 Record: https://patchnext.com/advisories/cve-2026-48776 (revision 3, source checked 26 Oct 2026, 13:49 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: langgraph 0.3.15; langgraph-sdk 0.3.15. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI langgraph: affected < 0.3.15; fixed in 0.3.15 - PyPI langgraph-sdk: affected < 0.3.15; fixed in 0.3.15 ## Suggested inspection (read-only) - `python -m pip show langgraph`: prints the installed version. Run with the environment that serves production active. - `python -m pip show langgraph-sdk`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on langgraph, langgraph-sdk. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-w39p-vh2g-g8g5 (OSV record GHSA-w39p-vh2g-g8g5 lists affected ranges: PyPI langgraph-sdk >=0 <0.3.15 (fixed)) - Verified: https://osv.dev/vulnerability/PYSEC-2026-2194 (OSV record PYSEC-2026-2194 lists affected ranges: PyPI langgraph >=0 <0.3.15 (fixed)) - Verified: https://github.com/advisories/GHSA-w39p-vh2g-g8g5 (GitHub-reviewed advisory GHSA-w39p-vh2g-g8g5 lists affected ranges: PyPI langgraph-sdk >=0 <0.3.15) Commands are suggestions: review each one before running it.
Loading voting…