Skip to content

← Actionable
Medium, CVSS 6.8amended

LangGraph Checkpoint: Unsafe JSON deserialization in checkpoint loading

CVE-2026-48775GHSA-fjqc-hq36-qh5p

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (langgraph-checkpoint 4.1.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.8 · CVSS:3.1/AV:A/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-48775: 0.23% estimated exploitation activity in the next 30 days; percentile 14.16 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary LangGraph's JsonPlusSerializer can reconstruct Python objects from JSON checkpoint payloads. Under conditions where someone could modify checkpoint bytes at rest in the backing store, the deserialization path could reconstruct objects beyond what the application expects, which could in turn result in code execution at checkpoint load time. This is a defense-in-depth issue. The affected behavior is reachable only when checkpoint bytes at rest in the backing store can be modified by an unauthorized party. In most deployments that prerequisite already implies a serious incident; the additional concern is turning "checkpoint-store write access" into code execution in the application runtime. There is no evidence of this behavior being triggered in the wild, and the team is not aware of a practical path to it in existing deployments today. This change is intended to reduce the surface available after a checkpoint-store incident. Affected users / systems Users may be affected if…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-fjqc-hq36-qh5p

  2. Revision 1 · created ·

    Published from osv record GHSA-fjqc-hq36-qh5p

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-48775

Advisory: LangGraph Checkpoint: Unsafe JSON deserialization in checkpoint loading
IDs: CVE-2026-48775, GHSA-fjqc-hq36-qh5p
Record: https://patchnext.com/advisories/cve-2026-48775 (revision 2, source checked 26 Oct 2026, 13:46 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: langgraph-checkpoint 4.1.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI langgraph-checkpoint: affected < 4.1.1; fixed in 4.1.1

## Suggested inspection (read-only)
- `python -m pip show langgraph-checkpoint`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on langgraph-checkpoint.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-fjqc-hq36-qh5p (OSV record GHSA-fjqc-hq36-qh5p lists affected ranges: PyPI langgraph-checkpoint >=0 <4.1.1 (fixed))
- Verified: https://github.com/advisories/GHSA-fjqc-hq36-qh5p (GitHub-reviewed advisory GHSA-fjqc-hq36-qh5p lists affected ranges: PyPI langgraph-checkpoint >=0 <4.1.1)

Commands are suggestions: review each one before running it.

Loading voting…